[CentOS-devel] Vagrant images for Hyper-V

Patrick Lang patrick.lang at hotmail.com
Mon May 1 03:37:16 UTC 2017


> >
> > We now have a working solution for producing regular .vhd images as part
> > of our release process: CBS is now using qemu-img-ev and qemu-kvm-ev from
> > the Virt SIG, instead of the versions in CentOS Linux base.  We don't need
> > either VirtualBox or changes in Image Factory.
> >
> > If anyone has access to Hyper-V on Windows and would be willing to test
> > two Vagrant images, please let me know.  I received conflicting test
> > results from Thomas and Michael, and I'd like to have at least an
> > additional test before deciding whether to release them or not.
> >
> > Thanks,
> > Lauren?iu
> >
>
> I just reached out to a friend on the Hyper-V team at MS to see if we can
> figure something out. It would be nice to have a way to automate this
> testing going forward.
>
> -Jeff

I emailed Laurentiu off list to get the boxes for 6.1.1 and 7.1.1.

I'm late to joining this discussion but I'm happy to help. I work on the Hyper-V team and have been doing some testing and improvements to Vagrant and Packer on the side.

re: sparse files - NTFS doesn't support sparse files, but Hyper-V does have dynamically expanding VHD and VHDX files. VHDX allocations are configurable but the default of 32MB is tuned to NTFS which puts all metadata at the beginning of the disk. Dropping VHDX allocations down to 1MB helps reduce the slack space left after each inode. VHD uses smaller allocations so it’s less of an issue. Both images are just over a gig on disk which is about what I’d expect.

If you’re optimizing the template Vagrantfiles in the boxes, it would be very helpful to add differencing_disk = true to avoid copying the full VHD and reduce IO in vagrant up.

Here's what I observed on each image

Centos 6.1.1 - Vagrant didn't find an IP address upon bootup. I logged in
via the console and the Hyper-V virtual NIC was on eth1 which didn't have
dhclient configured. I ran dhclient manually, then vagrant ssh was able to
find the IP

Centos 7.1.1 - Vagrant worked as expected. It found the IP as the VM booted
up.

I haven't fully tested everything but wanted to share some of the results. Let me know if there's a list of tests run against the other boxes and I can go through them.

Cheers,
Patrick Lang
(github.com/patricklang)

Sent from Mail<https://go.microsoft.com/fwlink/?LinkId=550986> for Windows 10

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.centos.org/pipermail/centos-devel/attachments/20170501/43e49fed/attachment.html>


More information about the CentOS-devel mailing list