[CentOS-devel] Running openshift cluster on aarch64

Jim Perrin jperrin at centos.org
Fri Sep 8 02:11:36 UTC 2017

Are the container structures smart enough to handle multiarch like this?
Last I looked at the code (admittedly about 6 months ago) there were
still some hard-coded x86_64 container pieces in the kube code and a
couple other places.

On 09/05/2017 11:33 PM, Bamacharan Kundu wrote:
> Hi,
>    I am trying to setup openshift allinone cluster in aarch64.
> I tried few ways.
> 1. RPM:
>   a. I installed the origin RPMs from the centos cbs [1]. started origin
> and while trying run the registry with pods it pulls the x86_64
> origin-pod and deployer. so fails with go panic.
>   b. tried running origin start, dockerregistry with config. pods are
> running but builds are not starting saying invalid registry endpoints
> (as it is trying to push the built image to internal registry)
> 2. Container based:
>   Built all the images (origin, origin-pod,
> origin-deployer,origin-docker-registry) in aarch64 from the origin
> dockerfiles[2]. started origin. then while deploying registry using
> `oadm registry --config`, deployer fails with `serviceaccount/token`
> file not found.
> any suggestion on how I can get this running on RPM based/ container
> based? or is it possible to run a hybrid arch openshift cluster? I meant
> running few nodes on x86_64 and few on aarch64/ppc64le.
> [1]
> https://cbs.centos.org/repos/paas7-openshift-multiarch-candidate/aarch64/os/
> [2] https://github.com/openshift/origin
> Regards
> Bamacharan Kundu
> _______________________________________________
> CentOS-devel mailing list
> CentOS-devel at centos.org
> https://lists.centos.org/mailman/listinfo/centos-devel

Jim Perrin
The CentOS Project | http://www.centos.org
twitter: @BitIntegrity | GPG Key: FA09AD77

More information about the CentOS-devel mailing list