[CentOS-devel] Vagrant / Centos 7 Install Error: Cannot find a valid baseurl for repo: base/7/x86_64

Tue Feb 20 19:45:36 UTC 2018
Laurentiu Pancescu <lpancescu at centosproject.org>

Hi Simon,

On 20/02/18 12:01, Simon Payne wrote:
> I am trying to get a Centos VM working with Vagrant + VirtualBox on Windows
> 8.  However I'm getting an error to do with the centos/7 box.
> I have installed Vagrant using its automated installer, and VirtualBox, and
> downloaded this box:
> https://app.vagrantup.com/centos/boxes/7
> Cannot find a valid baseurl for repo: base/7/x86_64
> I don't know how to fix it.  I append the error trace and my Vagrantfile.
> Any help will be appreciated.

I'm not sure what's going on,either.  VirtualBox users on Windows have 
been plagued by DNS problems immediately after centos/7 boots (disabling 
the NAT DNS resolver is an attempt to work around that).  I tried to 
simulate that by disabling the host networking immediately after running 
"vagrant up", and that produces the same error message you got.

I don't have access to Windows, so I ran your example on a Mac with 
VirtualBox 5.2.6, vagrant-vbguest 0.15.1 and centos/7 1801.02.  It 
installed the guest additions and mounted the shared folder via vboxsf. 
The DNS resolver problems were always restricted to VirtualBox on 
Windows - it works on Mac and Linux, as do all other hypervisors.  I'm 
afraid I can't help you; perhaps you can try to use our Hyper-V images 
(Hyper-V is included for free in Windows Professional and higher) or 
VMware, if that's an option.

Please note that the guest additions aren't really needed.  Networking 
works just fine without them, and you can use Samba or vagrant-sshfs for 
sharing files:


Best regards,