[CentOS-devel] [centos-devel] Ceph Storage SIG packages for Ceph Mimic

Sat Jun 9 06:39:06 UTC 2018
Thomas Oulevey <thomas.oulevey at cern.ch>

Dear All,

> Thanks for your reply, unfortunately I don't have the time to get a
> closer insight
As I had spare cycle I fixed the spec file and rebuilt/tagged dependencies.

I tried to rebuild ceph-13.2.0 for all enabled arches.

The status is the following :
- x86_64 OK [1]
- aarch64 / failing . logs can be found at [2] - [3]
- ppc64le OK [4]

You can check the results at http://cbs.centos.org and download TEST 
packages from there.

If you have experience with aarch64/ceph and you understand what is the 
issue please let us know.

I tried to lower the number of cpu/ram to 4 / 1G per process on the 
aarch64 builder. Max ram too was limited to half of the builder node 
capacity (8GB). No luck.

Please read the README on the sig-storage7-ceph-mimic branch on github 
[5] for the detailed changes from upstream.

I'll wait for feedback on the mailing list and continue to investigate.

- fix aarch64 build
- import in github new dependencies srpms
- what is our strategy for python3 support (should we leave it off ? or 
investigate a way to have python3-* in a CentOS SIG ? scl ? I didn't 
check how rhcs does it. All comments/ideas are welcomed!)
- build centos-release package for mimic


[1]: http://cbs.centos.org/koji/taskinfo?taskID=444924
[2]: http://cbs.centos.org/koji/taskinfo?taskID=444912
[3]: journaltctl output http://pastebin.centos.org/826181/
[4]: http://cbs.centos.org/koji/taskinfo?taskID=444933
[5]: https://github.com/CentOS-Storage-SIG/ceph)