[CentOS-mirror] CentOS5 Repository Question

John Lee john.lee at dtiteam.com
Mon Dec 17 16:38:32 UTC 2007


Can someone explain to me why my centos-5.0 repository has the following two rpm packages in the base repository, causing errors when running 'yum update', since it can't find the right dependencies?  

Here's the content of my repository for centos5.  Shouldn't hal- and gcc-4.1.2-14 belong in the 5.1 repository?  I compared it to http://mirror.centos.org/centos-5/5.0/os/i386/CentOS/ repository and it doesn't have the later versions of those two packages.  So why does my 5.0 repository have the following two packages timestamped Nov. 20?

[root at dragon os]# pwd
[root at dragon os]# ls -alh | grep hal-0.5
-rw-r--r--  1 root root  371K Apr  3  2007 hal-
-rw-r--r--  1 root root  375K Nov 20 11:12 hal-
[root at dragon os]# ls -alh | grep gcc-4
-rw-r--r--  1 root root  5.0M Apr  3  2007 gcc-4.1.1-52.el5.i386.rpm
-rw-r--r--  1 root root  5.3M Nov 20 11:11 gcc-4.1.2-14.el5.i386.rpm
-rw-r--r--  1 root root   82K Apr  3  2007 libgcc-4.1.1-52.el5.i386.rpm

Again, it's causing an error when runinng yum update because it's trying to update hal, and it can't find its dependcies since they're all located in the 5.1 repository.  The client is a 5.0 box.

Thank you,

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.centos.org/pipermail/centos-mirror/attachments/20071217/48bc7622/attachment.htm

More information about the CentOS-mirror mailing list