[CentOS-mirror] local mirror , weird connection reset by peer

Tue Dec 14 13:23:55 UTC 2010
Fabrizio Buratta <extremoburo at gmail.com>

Hi all,

I'm creating a CentOS mirror in my Centos 5.5  but I'm still unable to
sync my tree with any mirror because of this rsync error:

rsync: read error: Connection reset by peer (104)
rsync error: error in rsync protocol data stream (code 12) at
io.c(614) [receiver=2.6.8]
rsync: connection unexpectedly closed (365775 bytes received so far) [generator]
rsync error: error in rsync protocol data stream (code 12) at
io.c(463) [generator=2.6.8]

always at the same point ( random  kde package stucks until it returns
that error message  ):


I tried many mirrors but the problem persists. Also tried deleting and
starting from
scratch... no way it stucks at kde* packages.

I'm storing it on an exported NFS filesystem mounted correctly ( NFS
Server: Freenas 0.7.1 Shere).

It's odd that this is not working while a fedora mirroring runs
successfully every day on the same machine and same filesystem.

This is my script:


if [ -f /var/lock/subsys/centosmirror_rsync ]; then
    echo "Updates via rsync already running."
    exit 0

cd /var/www/mirrors   # this is a symbolic link to /var/www/nfs which
is where I mount my exported NFS

# Centos 5.5 sync
if [ -d CentOS/5.5 ] ; then
    touch /var/lock/subsys/centosmirror_rsync
    rsync  -avSHP --delete --exclude-from=centos-excludes.txt
rsync://ftp.df.lth.se/centos/5.5/ CentOS/5.5/
    /bin/rm -f /var/lock/subsys/centosmirror_rsync
    echo "Target directory CentOS/5.5 not present."

Any idea?

Thanks in advance!