[CentOS-pt-br] RES: CentOS e Vmware - Problemas de performance de disco

Allysson .\\oraes moraesab em gmail.com
Terça Novembro 10 14:55:12 UTC 2009


1) Verifica se você criou o disco da VM lenta pré-alocando o espaço do
disco, ao invés de alocação dinâmica;
2) Verifica se na VM está com o VMWARE TOOLS instalado


2009/11/10 Lincoln Zuljewic Silva <lincolnzsilva em gmail.com>

> Bom, a controladora de disco é a mesma nos dois servidores.
>
> Desabilitei também o parâmetro de virtualização na BIOS. Mesmo resultado.
>
> 2009/11/10 Lincoln Zuljewic Silva <lincolnzsilva em gmail.com>:
> > Obrigado pelos comentários. Seguem as respostas.
> >
> >> Vc checou a mover a VM de uma maquina para outra para ver se o
> comportamento
> > é o mesmo?
> > Sim, dentro do cluster movi a VM para outros hosts AMD e o resultado
> > foi o mesmo. Movi inclusive uma VM que estava no Intel pro AMD e a
> > performance piorou. Fiz também o contrário, movi uma que estava no AMD
> > para o Intel e a performance melhorou.
> >
> >> Na maquina 2 (AMD) existe RAID configurado? Ou acesso ao storage
> diferente
> > da Intel?
> > Sim, as duas tem RAID para os discos locais e HBA para acesso à
> > storage. Tando rodando a VM no disco local, quanto na storage o
> > resultado é o mesmo (Intel e AMD).
> >
> >> Eu acredito que o problema esteja relacionado às controladoras de disco.
> > Provavelmente a do servidor Intel deve ser diferente da do servidor
> > AMD. Procure checar isso.
> > Mesmo tendo os mesmo resultados tanto rodando a VM no disco local,
> > quanto na storage?
> >
> >> Verificou se na bios esta ativo o parametro de virtualização ? nos meus
> > o padrao é OFF . A R805 tem a tecnologia AMD-V disponivel para habilitar?
> > Essa é uma configuração que eu preciso confirmar no servidor (vou ter
> > que bootar). Pode ser uma solução. Estive dando uma lida em documentos
> > e relatos sobre esta tecnologia, alguns dizem que melhora, outros que
> > piora. Tenho que ver como está configurado hoje, inverter essa
> > configuração e testar.
> >
> > Abraços
> >
> > Lincoln
> >
> > 2009/11/9 Alexandre J. Correa - Onda Internet <
> alexandre em ondainternet.com.br>:
> >> Verificou se na bios esta ativo o parametro de virtualização ? nos meus
> >> o padrao é OFF ..
> >>
> >>
> >> Marcelo Gondim wrote:
> >>> Eu acredito que o problema esteja relacionado às controladoras de
> disco.
> >>> Provavelmente a do servidor Intel deve ser diferente da do servidor
> AMD.
> >>> Procure checar isso.
> >>>
> >>> -----Mensagem original-----
> >>> De: centos-pt-br-bounces em centos.org [mailto:
> centos-pt-br-bounces em centos.org]
> >>> Em nome de Lincoln Zuljewic Silva
> >>> Enviada em: segunda-feira, 9 de novembro de 2009 19:44
> >>> Para: Portuguese (Brazilian) CentOS mailing list
> >>> Assunto: [CentOS-pt-br] CentOS e Vmware - Problemas de performance de
> disco
> >>>
> >>> Boa noite lista.
> >>>
> >>> Estou com um pequeno problema aqui que está me deixando louco.
> >>>
> >>> Tenho um servidor Vmware Vsphere 4.0 rodando em um Power Edge R610 (2x
> >>> QuadCore Intel de 2.4Ghz e 32Gb de RAM).
> >>>
> >>> Neste primeiro Vmware tenho um CentOS 5.4 com um processador e 1Gb de
> >>> RAM rodando perfeito e como comparação, testes com o hdparm –tT me
> >>> retornam uma média de 9400 MB/s de “Timing cached reads” e 200 MB/s de
> >>> “Timing buffered disk reads”.
> >>>
> >>> Em outro servidor Vmware Vsphere 4.0 rodando em um Power Edge R805 (2x
> >>> QuadCore AMD de 2.5Ghz e 64Gb de RAM).
> >>>
> >>> Neste segundo Vmware tenho um CentOS 5.4 com um processador e 1Gb de
> >>> RAM rodando com lentidão de disco e para a comparação, o hdparm –tT me
> >>> retorna uma média de 2000 MB/s de “Timing cached reads” e 127 MB/s de
> >>> “Timing buffered disk reads”.
> >>>
> >>> Tendo em vista que a instalação do CentOS foi idêntica (mesmos pacotes
> >>> e particionamento) e que a única diferença entre o HW físico do Vmware
> >>> é o tipo da CPU (um é Intel e outro AMD), pode-se observar uma grande
> >>> diferença nos resultados do hdparm (rodei cinco vezes o hdparm em cada
> >>> servidor para fazer uma média).
> >>>
> >>> Alguém sabe dizer se existem alguma limitação/bug/algo relacionado à
> >>> processadores AMD e performance do disco?
> >>>
> >>> Digo também que os discos físicos locais dos servidores são iguais.
> >>>
> >>> Esta lentidão foi percebida, pois no servidor lento existe um Mysql
> >>> rodando e as queries que demoram 2 minutos para rodar nele, demoram 10
> >>> segundos para rodar no outro.
> >>>
> >>> Já recompilei o kernel do servidor lento e alterei o tipo de CPU para
> >>> AMD, porém não obtive melhores resultados.
> >>>
> >>> Acho que o tipo de CPU não tem muito a ver com a performance do disco,
> >>> mas esta é a unica diferença entre os servidores fisicos.
> >>>
> >>>
> >>>
> >>>
> >>> __________ Informação do ESET NOD32 Antivirus, versão da vacina 4585
> >>> (20091108) __________
> >>>
> >>> A mensagem foi verificada pelo  ESET NOD32 Antivirus.
> >>>
> >>> http://www.eset.com
> >>>
> >>>
> >>> _______________________________________________
> >>> CentOS-pt-br mailing list
> >>> CentOS-pt-br em centos.org
> >>> http://lists.centos.org/mailman/listinfo/centos-pt-br
> >>>
> >>>
> >>
> >>
> >> --
> >> Sds.
> >>
> >> Alexandre Jeronimo Correa
> >>
> >> Onda Internet
> >> www.onda.net.br
> >>
> >> IPV6 Ready !
> >> www.ipv6.onda.net.br
> >>
> >> _______________________________________________
> >> CentOS-pt-br mailing list
> >> CentOS-pt-br em centos.org
> >> http://lists.centos.org/mailman/listinfo/centos-pt-br
> >>
> >
>
>
>
> --
> Lincoln Zuljewic Silva
> More contact info.: http://www.system.adm.br/contact.php
>
> "How often must a question be asked before it’s considered a
> frequently asked question?"
> _______________________________________________
> CentOS-pt-br mailing list
> CentOS-pt-br em centos.org
> http://lists.centos.org/mailman/listinfo/centos-pt-br
>



-- 
,_______,________,______,,___
,___,,,,|___,,__,)___,,,|/,,/
,__,,/|,|__,,__,,|__,,/|_/,/
,_,,___,|_,,/_/,/,_,,/,,/,/
,/_/,,|_|/_____/,,/_/,,/_/
AlLySsOn .\\oRÆs
-------------- Próxima Parte ----------
Um anexo em HTML foi limpo...
URL: http://lists.centos.org/pipermail/centos-pt-br/attachments/20091110/7bfaa255/attachment.html 


Mais detalhes sobre a lista de discussão CentOS-pt-br