[CentOS-virt] xenbr0 isn't created anymore

Tue Apr 1 18:19:58 UTC 2008
Kai Schaetzl <maillists at conactive.com>

Ross S. W. Walker wrote on Tue, 1 Apr 2008 11:14:58 -0400:

> Yeah, I would use xenbr0 (or eth0 in 3.2 parlance) as the bridge
> if you plan on using an external DHCP server and avoid the
> whole NAT and dnsmasq mess. I would probably use virbr0 as a
> nice virtual network only service, remove forwarding and NAT
> on it and keep it for internal traffic only.

virbr0 ist just there when libvirtd gets started, it's useless as it is 
not bridged to anything anymore. However, I'm not able to reproduce my 
last results consistently. As expected once I rebooted the problem was 
back and now I can start libvirtd, kill dnsmasq and still get no IP 
address. I also found a posting on xen-users that describes exactly my 
problem and solution

and the solution is in that direction I suspected. I tried that and again 
it doesn't work consistently for me. If I do "iptables -A FORWARD -s -d -j ACCEPT" it seemed to work first, but then stopped 
working as well. I now get an IP when booting up the VM, but it doesn't 
last long as the reacknowledgement doesn't travel back.

So, bridging and networking is fine except for DHCP, damn.


Kai Schätzl, Berlin, Germany
Get your web at Conactive Internet Services: http://www.conactive.com