[CentOS-virt] Problem with keyboard layout

Erik Edelmann edelmann at csc.fi
Wed Aug 20 13:07:25 UTC 2008


I'm trying to set up a fully virtualized server using Xen; both host and
guest operating system is CentOS-5.2.  Otherwise it seems to work fairly
well, but I can't get my finnish keyboard work correctly for the
guest (when using virt-viewer. No problems on the host).

In the beginning, using default settings, the behaviour was as if the
keyboard layout had been set to "U.S. English". Trying to set the keyboard
layout using administration tools inside the guest had no effect. I also

         vfb = [ "type=vnc,vncunused=1,keymap=fi" ]

in the guest config file, and

         (keymap 'fi')

in xend-config.sxp, as suggested by
http://wiki.centos.org/TipsAndTricks/Xen, but neither of those had any
effect either.  Setting

         keymap = "fi"

in the guest config file improved the situation a bit, but there were still
a few keys that behaved oddly, e.g. [shift]-[6] gave "K" (should give "&")
and ['] gave "b" (should give "'").

I then tried swedish keyboard layout, by setting

         keymap = "sv"

in the guest config file (swedish and finnish keyboards are, I think, the
same). That fixed most problems, with only one remaining (as far as I've
noticed this far): The [tilde, circumflex, diaeresis]-key won't work. Pressing that
key gives nothing, and that key + space gives just space (with and 
without shift or altgr).

Any helpful ideas?


More information about the CentOS-virt mailing list