[CentOS-virt] VMware Server clock woes (running too fast)

Wed Aug 20 12:37:25 UTC 2008
Michael Ekstrand <michael at elehack.net>

"Akemi Yagi" <amyagi at gmail.com> writes:
> On Tue, Aug 19, 2008 at 5:55 PM, Michael Ekstrand <michael at elehack.net> wrote:
>> I'm running VMware Server 1.0.6 on a CentOS 5.2 host and am having some
>> clock difficulties.
>> Host OS is x86_64 running on 1.9 GHz AMD Sempron, nVidia chipset.
>> Guest OS's are 32-bit FreeBSD (clock works fine after disabling ACPI,
>> setting the clock source to the PIT, and running the guest tools), WinXP
>> (unknown clock status), and i686 CentOS 5.2 (here is the problem).
>> I've tried pretty much everything to try to fix it.  I have host.cpukHz,
>> host.noTSC, and ptsc.noTSC set in /etc/vmware/config.  I've booted my
>> kernel with noapic, nosmp, noacpi, divider=10.  Sadly, I hit the
>> clocksource=pit with divider bug, so I have not been able to boot with
>> both that and divider=10, although clocksource=pit without a divider
>> also does not work.  I even built a custom kernel with SMP and APIC
>> disabled, CPU_HZ=100, and booted with clocksource=pit noacpi, and it
>> also gains time.
>> Could anyone provide a recommendation as to what I can do to fix this problem?
> I understand you built a 100Hz kernel, but *just in case*, you might
> want to try CentOS-supplied 100Hz kernel (kernel-vm) available from:
> http://people.centos.org/tru/kernel-vm/

Just tried it, and it doesn't seem to work. I used the following

 nosmp noapic nolapic noacpi clocksource=pit

> Also, enable time sync with host if that has not been done.

Already done, and was active throughout the problems described above.

I seem to remember seeing somewhere or another something about a
different set of timing devices available on 64-bit vs. 32-bit.  When I
was previously using 32-bit Debian Etch as the host OS on this same
hardware with an upgraded (2.6.22) kernel, I had no noticable timing
problems on the FreeBSD guest (didn't run Linux guests enough to notice
anything).  After switching to 64-bit CentOS host OS, the FreeBSD guest
clock started running fast, but it responded to adjustments and keeps in
line with the setup described above.  Is it possible that running the
64-bit host environment is what is causing my problems?  Are there host
options I can tweak to try to improve the situation?

- Michael

mouse, n: A device for pointing at the xterm in which you want to type.
Confused by the strange files?  I cryptographically sign my messages.
For more information see <http://www.elehack.net/resources/gpg>.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 196 bytes
Desc: not available
URL: <http://lists.centos.org/pipermail/centos-virt/attachments/20080820/d0d7e109/attachment-0004.sig>