[CentOS-virt] Xen performance (very slow) problem with 4GB of RAM.

Sun Feb 3 17:23:10 UTC 2008
Michael Olson <olson at irinim.net>

I just took the x64 CentOS 5.1/Xen system I've been working on and 
upgraded from 2GB to 4GB of memory. Fresh minimal install of the OS (to 
remove some 3.2 stuff I had done trying to make PCI passthrough work). 
No special options, just a flat out default install.

Dom0 is incredibly slow, I haven't tried DomU's yet to see if they are 
affected. X in particular is impressively slow (you can watch the screen 
be filled in one little block at a time, with several seconds between 
blocks) but it's not just video apps, it takes a considerable amount of 
time for the Xend daemon to start during boot. Before worrying about it 
I updated everything, same problem. Nothing interesting looking in dmesg 
or /var/log/messages.

I tried out the vanilla kernel and it booted/ran well, no sign of the 

Next, I tried Dom0 limited to 1.5GB (kernel /xen.gz-2.6.18-53.1.6.el5 
dom0_mem=1536M), and it performed well.

This workaround is probably adequate for me, I haven't found what the 
boundary conditions are on the problem and I haven't tested DomU 
performance yet. A Google and BugTracker search didn't turn this problem 
described elsewhere, is this known or is this something unique to me?

-- Michael