[CentOS-virt] Problem with CentOS 5.1/xen/RTL8110

Tue Jan 8 13:51:03 UTC 2008
Chris Gow <chris.gow at gmail.com>


I'm having issues with my CentOS 5.1/Xen installation. If I run the 
xen-bridge, I seem to get flaky ethernet. By flaky I mean everything seems 
fine from the host machine, but if I attempt to contact the host machine from 
another remote machine (eg. my laptop which is on the same subnet as the xen 
machine, separated by 10 ft of cable and a router) I either get extremely 
high ping times or Destination Host Unreachable. Ditto with ssh. I've 
disabled the firewall and it does not make a difference. If I stop the 
xen-bridge (/etc/xen/scripts/network-bridge stop) then I get what I would 
consider normal network access to the xen machine.

Hardware: Gigabyte GA-G33M-S2H MB (Realtek R8110SC onboard nic)
OS: CentOS 5.1 64bit Xen

I installed CentOS last night with the Xen kernel, the stock kernel did not 
support my nic which I was aware of. So I downloaded the r1000 source rpm 
from the centos wiki, built and installed it. Once I did that the card was 
detected (an ifconfig would actually display eth0), but it would never get an 
IP address (the xen machine is configured for dhcp at the moment). Today, I 
installed the non-xen kernel, applied the non-xen r1000 kernel module and the 
onboard nic was found and working. 

I then grabbed the updates from centos, saw that there were some kernel 
updates, applied the r1000 kernel modules again, restarted and (the non-xen 
kernel) eth0 was still happy. Good. Restarted again, but booted into the xen 
kernel, eth0 was still happy. eth0 would get an IP address, and was able to 
see the outside world. However, the outside world (eg. my laptop) could not 
see the xen machine or it could inconsistently. That is, ping times would be 
extremely high (on the order of 2+ seconds) or I would get Destination Host 
Unreachable errors. Trying to connect via ssh would also be sporadic. 

Thinking it might be firewall related, I disabled the firewall. There was no 
change in behaviour. I then disabled the xen-bridge and was able to ping with 
reasonable numbers (<200ms) and connect via ssh. Just to note though, after I 
stopped the bridge I immediately tried to connect via ssh/ping and did not 
get through, so I ran service iptables stop (again) and then was able to get 
correct network access. I'm not sure if stopping iptables again did anything 
(I doubt) or I did not leave enough time from stopping the bridge to letting 
everything get reconfigured.

I'm not sure what the problem is or how exactly to troubleshoot it. The NIC is 
slightly different than the one specified in the CentOS wiki (the wiki 
mentions RTL8110 and RTL8169SC and mine is a RTL8110SC) but I'm not familiar 
enough with the devices to know how much of a big deal that is, if any. Also, 
just to be clear, the problem is other physical machines have a difficult 
time accessing the xen host pc when the xen-bridge is running. I have not 
gotten as far as creating a VM yet.

Any assistance would be great.


-- chris