[CentOS-virt] Very high cpu waiting on xen domU

Frederic SOULIER frederic.soulier at univ-tlse1.fr
Fri Oct 31 10:49:31 UTC 2008


I have some xen domU on Centos 5.2 server.
For some weeks i had a problem with "xen domU" performances.
Indeed my xen domU spend a lot of time in cpu waiting.

Reading some informations on the net it seems to come ith I/O heavy load.
Using collectd in my domU to monitor the "traffic" on virtual disk and 
virtuel network i don't see heavy I/O rates.

Thinking my dom0 was overloaded by my domUs i have stopped all my domUs 
except one but the problem persist.
I don't know how to get more informations in order to solve my problem.

For information our config is :
  - Hitachi SAN infrastructure
  - DELL 1950 servers with 2 qlogic hba adapters (we used qla2xx drivers 
and linux dm-multipath for multipathing )
  - We have 1 LUN on the SAN for each domU
  - The dom0 manage theses LUNs using LVM
  - A domU xen disk configuration looks like this : disk = [ 
  - In the domU we doesn't use LVM.
 - At the network level we share a gigabit interface with all the domU 
using linux bridges. Each bridge refer to a different vlan.

Anyone encoutered I/O performances problems with latests centos 5.2 xen 
releases ? (In fact i don't really understand if it's a xen problem or a 
"hardware" problem)



Frederic Soulier

Administrateur Reseau
Centre de Ressources Informatiques
Université Toulouse 1 Sciences Sociales
Tel : +33 5 61 63 39 98 / +33 5 61 63 39 98
Fax : +33 5 61 63 37 98   Bureau : AR38 bis

More information about the CentOS-virt mailing list