[CentOS-virt] Can't get PCI card visible in guest

Thu Oct 30 23:28:58 UTC 2008
Todd Deshane <deshantm at gmail.com>

On Thu, Oct 30, 2008 at 7:12 PM, Kenneth Tanzer <ktanzer at desc.org> wrote:

> I tried this a couple of ways.  If I add just the kernel file, and not the
> parameters, like so:
> kernel="/boot/vmlinuz-2.6.18-92.1.13.el5xen"
> ramdisk="/boot/initrd-2.6.18-92.1.13.el5xen.img"


> It starts booting, but then dies with:

> Kernel panic - not syncing: Attempted to kill init!
> If I add the "ro root=/dev/VolGroup00/LogVol00" to the kernel line, I either
> get a kernel not found message (if the parameteres are inside the quotation
> marks), or an invalid parameter message (if outside the quotes).  I tried
> adding:
> root="/dev/VolGroup00/LogVol00"

> (with and without a "ro" at the end), and it still boots the kernel but then
> panics.  Which is what I'm starting to do! :)

add the ro and any of kernel parameters to an extra boot parameter

I am not seeing the errors in the red hat based boot that I am familiar
with, but it seems that you are running into one of the following (or

Your guest root file system is not where you expect it to be.
If you haven't already, check the grub.conf in the guest.


You are missing modules in your ramdisk that are needed by your guest
(in which case you would need to use mkinitrd to rebuild your xen initrd
and make sure you include the necessary modules)


Some combination of the above, you should be able to pretty closely
mirror the kernel command line
with the combination of kernel, root, and extra parameters.

The only tricky part would be to rebuild with any missing modules.

Hope that helps,

Todd Deshane