[CentOS-virt] KVM Support for Windows Server 2003 32 bit ready for production?

Kenni Lund kenni at kelu.dk
Wed Dec 2 21:51:48 UTC 2009

2009/12/2 Neil Aggarwal <neil at jammconsulting.com>:
> I am wondering if KVM is ready for production
> for running a Windows Server 2003 32 bit guest.

Well, it probably depends on who you ask... :) With the current
qemu-kvm branch, I would say yes. I've been running a (non-critical)
Windows Server 2003 32bit in a production environment with Fedora 8,
Fedora 9 and now Fedora 11. A Windows 2008 Server 64bit guest also
joined in at Fedora 9. Back in the Fedora 8 and 9 days, I experienced
some issues, but they're all resolved now in Fedora 11 (and hopefully
also in Fedora 12). Since they're running perfectly fine now, I'm not
in a hurry moving to CentOS 5.4 for a more overall stable platform.
Instead I'm waiting for CentOS 6.0 to arrive next year, in which the
Xen support will be dropped and KVM will be the primary virtualization
solution. I have no issues of reaching uptimes of 90 days+ for the two
Windows servers or the three Linux guests with my current Fedora 11
installation (if I skip the updates requiring a restart).

> According to the RHEL 5.4 virtualization guide,
> there is supposed to be a virtio-win yum package,
> but that was not released.  Instead, it looks like
> that is only available for RHN subscribers.

Yep, it was actually released yesterday to the Red Hat Supplementary repository:

I guess Red Hat has copyrighted their binary version, since they put
it in the Supplementary repository. As I couldn't figure out if
packages (especially virtio-win) from the supplementary repository
sometimes find their way into CentOS, so I created a question about it
in the forums earlier today:

> --- Quoted from CL Martinez
> There are freely redistributable, but still they aren't published by
> upstream. You
> can use these instead:
> http://www.linux-kvm.com/content/windows-binary-virtio-drivers-finally-relea
> sed, but
> there are a lot of problems with any windows 64 bits. And another problem, a
> big
> really, is that you can¡t install a windows kvm guest directly to a virtio
> disk.
> First you need to install to an ide disk, after generate a virtio disk and
> attach to
> win guest, install the virtio driver and last remove ide drive ... very very
> ugly.
> ---- End Quote

Well, the drivers works just fine for 64 bit guests, but they're
tricky to install in their current form, since they _NEED_ to be
signed correctly...if you sign them yourself, you'll need to enable
test mode in Windows, which indeed is just as ugly as the "add a
secondary harddisk to install the virtio drivers" fix. This is exactly
why we need the virt-win package, which apparently both contain an iso
with *.msi files for installing the drivers within Windows, as well as
a floppy image for installation of drivers during the installation of

The ugly part is the installation of unsigned VirtIO block device
drivers...if you can live with e1000 NIC emulation (close to same
performance, but a bit higher CPU utillization) and IDE emulation,
then you shouldn't have any stability issues and no "ugly hacks".
Performance should still be fairly good.

You you, like me, don't mind a bit of hacking on the initial
installation of a Windows Server, running with NIC and block VirtIO
drivers should be just as stable (today I'm running VirtIO on all my
Windows and Linux systems).

Best Regards
Kenni Lund

More information about the CentOS-virt mailing list