[CentOS-virt] Has anyone gotten Fedora 12 running as a Xen guest?

Tue Dec 1 17:35:12 UTC 2009
Scot P. Floess <sfloess at nc.rr.com>

I am running CentOS 5.4 (both i386 and x86_64 - different physical 
machines)...  I've been able to get Fedora 11 running as a Xen guest - no 
trouble.  However, I have had no luck with Fedora 12.  My kickstart file 
lists /boot as ext3 - but for whatever reason Fedora 12 insists on making 
/boot ext4.

I do have a bare metal machine running Fedora 12, so I thought "let me try 
to put together a kickstart file denoting /boot as ext3."  I ran 
system-config-kickstart and about the only difference I saw in syntax was 
--fstype="ext3" versus what I was doing which is --fstype ext3

So, I changed my kickstart file to reflect --fstype="ext3" - the result is 
still the same:  Fedora 12 insists /boot be ext4.  As a result, when I run 
xm create <fedora vm name>, it fails stating "Error creating domain: Boot 
loader didn't return any data!"

Please note, this is the same kickstart file I use to install CentOS 5.4 
(and in the past 5.3) guests - as well as Fedora 11 guests.

Has anyone managed to get Fedora 12 running as a Xen guest???

Scot P. Floess
27 Lake Royale
Louisburg, NC  27549

252-478-8087 (Home)
919-890-8117 (Work)

Chief Architect JPlate   http://sourceforge.net/projects/jplate
Chief Architect JavaPIM  http://sourceforge.net/projects/javapim

Architect Keros          http://sourceforge.net/projects/keros