[CentOS-virt] vmware problem took down X on host?

Mon Jan 19 02:31:42 UTC 2009
Ted Miller <limaohio123-CompMailLists at yahoo.com>

Tru Huynh wrote:
>Ted Miller wrote:
>> I run VMWare server 1.07 on Centos 5.

Upgraded to 2.0 now.

>> Last night I left a Windows 2000 
>> virtual machine doing a ClamWin scan of drive M: when I went to bed around 
>> midnight.  Drive M: is actually a volume on the Centos 5 host, mounted via 
>> Samba.  It has about 40Gb of photos on it, plus a few other things.  I had 
>> the VM up visible in the VMWare Server Console running under KDE on display 
>> 8 (X session #1), my usual configuration.

> why don't you just run clamscan from CentOS to the local storage instead
> of using a guest OS on vmware server + clamwin + samba? ;)

I have to have it installed to do the C: drive on the VM, so just ran it on 
the mounted volumes too.  I can do it all via that install, but an install 
on Centos cannot do the virtual drive.  I don't want to maintain two 
installs when one will do fine.

>> This morning when I looked in on it the screen was not responsive.  The 
>> keyboard seemed to be working (num lock would go on and off, though 
>> sometimes with some delay). 

> some kernel panic lights (sos in morse?)

No, normal keyboard lights.  I tried NumLock when I could not get the 
monitor to come on, to see if there was any life.  The NumLock light did 
respond to the NumLock key, so I knew that the kernel was still running.

In my original post I detailed how I was eventually able to get a bash 
console to come up, and get the computer to reboot.

>> After the reboot, things seem pretty normal.  However, I found this in 
>> /var/log/messages, and wonder what they mean, especially the one at 
>> 04:02:08 about debug info.

> X server crashed (nvidia driver crashed? or hardware issue on the video card or
> the mainboard) then samba crashed

I updated the nvidia driver.  Did have one other Xserver crash today. 
Didn't loose anything important, just all of the sudden got flipped out to 
the login prompt.  I had another Xserver terminal open, but it was not 
affected by that crash.

Ted Miller
Indiana, USA