[CentOS-virt] Fedora 12 domU on CentOS 5.4 2.6.18-164.6.1.el5xen fails to boot

Mon Nov 23 20:56:18 UTC 2009
Andri Möll <andri at dot.ee>

This looks like your host doesn't support the filesystem your domU's
using.  I think Fedora's on ext4 by default.  One solution is to use
ext2/ext3 for the domU's boot media or partition.


On Mon, 2009-11-23 at 15:41 -0500, Charles J Gruener wrote:
> Doing a kickstart install of Fedora 12 results in a non-bootable image.
> >From a virt-maanger instance, the error produced when trying to run the domU is:
> Traceback (most recent call last):
>   File "/usr/share/virt-manager/virtManager/engine.py", line 498, in run_domain
>     vm.startup()
>   File "/usr/share/virt-manager/virtManager/domain.py", line 573, in startup
>     self.vm.create()
>   File "/usr/lib64/python2.4/site-packages/libvirt.py", line 287, in create
>     if ret == -1: raise libvirtError ('virDomainCreate() failed', dom=self)
> libvirtError: POST operation failed: xend_post: error from xen daemon: (xend.err "Error creating domain: Boot loader didn't return any data!")
> If you drop to the command line to see what pygrub gets back, you get:
> # pygrub /var/lib/xen/images/fedora12.img
> Traceback (most recent call last):
>   File "/usr/bin/pygrub", line 677, in ?
>     fs = fsimage.open(file, get_fs_offset(file))
> IOError: [Errno 95] Operation not supported
> The kickstart worked perfectly in Fedora 11 on a CentOS 5.4 dom0.
> I've tried investigating all sorts of grub options and even tried copying kernel and initramfs files out from the domU to dom0 and booting from those with no luck.  The only thing that does work is if I install Fedora 11 and then perform an upgrade to Fedora 12.  I really don't want to have to deploy machines this way.
> Is anyone else experiencing this issue?  I can provide any further information requested.  Basically, to repeat my error, install CentOS 5.4 with Virtualization, then try to install a Fedora 12 domU.  The installation finishes without error but you can't boot.  The systems are all x86_64.
> Thanks.
> Charles
> _______________________________________________
> CentOS-virt mailing list
> CentOS-virt at centos.org
> http://lists.centos.org/mailman/listinfo/centos-virt