[CentOS-virt] KVM: 'ÿ' character after starting a VM via virt-install

Wed Apr 28 18:06:01 UTC 2010
compdoc <compdoc at hotrodpc.com>

I’m guessing the hardware has virtual abilities enabled in the bios


This problem you have once happened to me, and from what I can remember it
had something to do with storage. These days I use block devices, which is
faster. If you’re using file-based, I guess you might want to check
permissions for the directory you’re putting them in, as well as permissions
for the .iso file you’re installing from.


Also, make sure you are not running the zen kernel – KVM requires the normal
x86_64 kernel.  Using the package manager to list my kvm components:


etherboot-zroms-kvm.x86_64   5.4.4-10.el5.centos          installed

kmod-kvm.x86_64                          83-105.el5_4.28

kvm.x86_64                                        83-105.el5_4.28

kvm-qemu-img.x86_64                 83-105.el5_4.28                installed


uname -a:  Linux centos.domain.com 2.6.18-164.15.1.el5 #1 SMP Wed Mar 17
11:30:06 EDT 2010 x86_64 x86_64 x86_64 GNU/Linux




From: centos-virt-bounces at centos.org [mailto:centos-virt-bounces at centos.org]
On Behalf Of gibbe gabba
Sent: Wednesday, April 28, 2010 1:06 AM
To: Discussion about the virtualization on CentOS
Subject: Re: [CentOS-virt] KVM: 'ÿ' character after starting a VM via


The hardware is DELL PowerEdge R210 Quad Intel(R) Xeon(R) CPU X3430  @
2.40GHz (/proc/cpuinfo).

I installed KVM with .RPMs after installing the system with a base Centos
5.4 installation (server).
yum install kvm
yum install virt-install

the kvm and kvm_intel modules are loaded. Also HyperThreading is available
(enabled in BIOS), so KVM isn't complaining about that.

I've tried following Linux distros:

- Centos 5.4
- Fedora 12
- Ubuntu 10
- Sipcat 1.3

All of them have the same problem. I tried both installing from a CD ISO and
from http repositories.

On Mon, Apr 26, 2010 at 4:53 PM, compdoc <compdoc at hotrodpc.com> wrote:

Just curious as to what hardware you're running it on. And when you say
you've installed the necessary rpms, does this mean you installed KVM by
hand after the install, or through the installer when you first installed




From: centos-virt-bounces at centos.org [mailto:centos-virt-bounces at centos.org]
On Behalf Of gibbe gabba
Sent: Monday, April 26, 2010 7:02 AM
To: centos-virt at centos.org
Subject: [CentOS-virt] KVM: 'ÿ' character after starting a VM via


I'm unable to start a virtual machine with KVM.

I'm using Centos 5.4

I have installed all necessary rpms (to my knowledge), but as you can see
from the output (below), the system does not boot the CD-ROM. It just sits
there doing nothing:

# virt-install --prompt

Would you like to use KVM acceleration? (yes or no) yes

 What is the name of your virtual machine? test

 How much RAM should be allocated (in megabytes)? 1024

 What would you like to use as the disk (file path)?

 How large would you like the disk (/var/lib/libvirt/images/test.img) to be
(in gigabytes)? 20

 What is the install CD-ROM/ISO or URL? /root/CentOS-5.4-i386-bin-1of6.iso

Starting install...

Creating storage file...                                          |  20 GB

Creating domain...                                                |    0 B

Connected to domain test

Escape character is ^]


the 'ÿ' character appears after a few seconds, then nothing... Error!
Filename not specified.

Any help is appreciated! 

CentOS-virt mailing list
CentOS-virt at centos.org


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.centos.org/pipermail/centos-virt/attachments/20100428/ddd78807/attachment-0005.html>