[CentOS-virt] CentOS, Xen and VLANs

Tue Aug 10 05:58:26 UTC 2010
Jared Ravetch <jravetch at gmail.com>

I ran into an issue when trying to create VMs in CentOS 5.5 with VLANs.  My
setup is as follows:

-CentOS 5.5 x64 xen kernel
-LVM for storage
-Kickstart file hosted on apache in /var/www/html/
-VM start file in /etc/xen/
-VLAN100 interface with public IP, VLAN200 interface with private IP

My vm start file is as follows:

kernel = "/boot/vm-inst/vmlinuz"
ramdisk = "/boot/vm-inst/initrd.img"
name = "vm1-inst"
memory = 1000
disk = [ 'phy:/dev/VolGroup01/vm01,xvda,w', ]
vif = ['bridge=virbr0', ]
vcpus = 1
ip = ''
netmask = ''
gateway = ''
extra = "text ks= ip=
netmask= gateway= dns="

To start the install I run:
xm create -c vm1-inst

The CentOS installer finds the kernel and ramdisk files, configures the IP,
then hangs for a while until it states it cannot find the kickstart file.

I have to then have to exit the console and shutdown the vm

To remove any issues with the kickstart file, I tried just using vm-install
--prompt to create the VM and pointing to a FTP site with the install files.
The CentOS installer starts, I configure the IP using a static IP, but then
the it complains it cannot find any files in the FTP site.

Finally, I tried using the CentOS DVD ISO as the install media for the VM.
The installer starts, but then complains it does not have the drivers to
load the media. I googled and found this is a limitation of CentOS when
creating VMs.

Has anyone had experience getting the installer over VLANs to work with a
network install? Is there another way around this issue?

Thanks and Regards,
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.centos.org/pipermail/centos-virt/attachments/20100810/a4c27d55/attachment-0005.html>