[CentOS-virt] VMWare 4.1 and CentOS

Nataraj incoming-centos at rjl.com
Mon Oct 25 20:33:06 EDT 2010

Drew Kollasch wrote:
> Is there any known issues when trying to run CentOS (x86 or x64) on a 
> fresh install of vmware 4.1?
> Details as to why I am asking are here in the CentOS 
> forums: https://www.centos.org/modules/newbb/viewtopic.php?viewmode=flat&order=DESC&topic_id=28521&forum=39 
> <https://www.centos.org/modules/newbb/viewtopic.php?viewmode=flat&order=DESC&topic_id=28521&forum=39>
> Thanks!
> -Drew
> ------------------------------------------------------------------------
> _______________________________________________
> CentOS-virt mailing list
> CentOS-virt at centos.org
> http://lists.centos.org/mailman/listinfo/centos-virt
What OS and kernel version have you configured your ESX virtual machine 
for?  Are you at all trying to run a non standard kernel?  The OS/kernel 
version settings on vmware are not just for for informational purposes, 
but instead vmware makes very specific assumptions about what clocking 
options (and possible other things) are configured in your kernel based 
on these settings.  It assumes, for example that Redhat 5 does NOT use a 
tickless kernel and that all recent releases of Ubuntu do use a tickless 
kernel.  If you choose a setting that is too far off from the kernel 
your running, you will have major clocking issues  and your machine may 
not run.

I discovered this when I had a VMware virtual machine from a hosting 
provider and was having problems.  Finally, I was able to write a small 
program which did a select with a timeout, that would not run in the VM, 
but ran in other places.  I called the hosting provider and asked them 
to read me the vmware config parameters for my VM and sure enough I was 
running CentOS 5 and they had configured my VM as Ubuntu.  They changed 
that to Red Hat and all my problems went away.


More information about the CentOS-virt mailing list