[CentOS-virt] xm attach-block reboots entire server

Wed Jul 6 17:17:15 UTC 2011
Steve Campbell <campbell at cnpapers.com>

On 7/6/2011 10:42 AM, PLD wrote:
> On 06/07/2011 13:03, Steve Campbell wrote:
>> I'm still trying to get xen working before Centos 6 and KVM just for
>> experience. I seem to be able to do most of what I what with VMs, but
>> I've run into another problem with CD/DVDs.
>> I can get a DVD mounted on the host domain just fine, but when I try and
>> attach-block to a running guest VM, the entire server reboots. I've
>> tried many different commands versions based on what Google finds, but
>> I'm not getting anywhere. I end up using scp to copy the data from the
>> host to the guest.
>> The guest is basically defined as a full virtualized domain. I'm using
>> /dev/scd0 as the device (it's listed on the mount command) as both
>> frontend and backend devices. And I've tried a few other devices as
>> well, but the same result.
> This should be easy. Use attach-disk, not attach-block. Unmount on the 
> host before mounting on the domU. See the attach-disk commands in my 
> reply to one of your other mails. The device is /dev/sr0 on SL6. Give 
> it a go, and post your exact commands.
> BTW, I gave up waiting for Centos-6 long ago. SL6 works just fine with 
> KVM. Haven't tried Xen on it yet - my Xen domains are on F8.

Google, in this case, was not my friend, since it pointed me to 
attach-block instead of attach-disk. Rereading the previous emails, I 
see where I was errant in using what google was suggesting.

Thanks for the help, all.