[CentOS-virt] My CentOS in VMware can't find my wireless card

Thu Jun 9 01:59:31 UTC 2011
liming wu <wuliming2010 at gmail.com>

Thank you for your reply.
>First off. Which VMWare program are you using?
My VMWare in use is station, the following information comes from my VMWare:
Product:VMware® Workstation
Version:7.1.2 build-301548
Host OS version:Windows XP Professional 5.1.2600, Service Pack 3
>what's the output of "lsusb"?
Here is the output :
[root at wulmcent ~]# lsusb
Bus 001 Device 001: ID 0000:0000
Bus 001 Device 002: ID 0cf3:1006 Atheros Communications, Inc.
Bus 002 Device 001: ID 0000:0000
[root at wulmcent ~]#
So i think my CentOS(2.6.18-128.el5) in VMWare has recognized my usb device,
but the system can't drive it.
The light in my wireless card is still off.
On the other way, i have tried the ndiswrapper(1.56) using the drivers on
My wireless card can work well on winXP.So i think the driver will work in
centOS too.
In fact, it cound't work although i've tried every driver i have that work
well on winXP.
Here is my try:
[root at wulmcent MW54U]# ls
150U  C69  U300T  U70  UD10
[root at wulmcent MW54U]# cd U70
[root at wulmcent U70]# ls
athur.sys  athuw.sys  netathuw.inf
[root at wulmcent U70]# ndiswrapper -i netathuw.inf
driver netathuw is already installed
[root at wulmcent U70]# ndiswrapper -l
netathuw : invalid driver!
[root at wulmcent U70]#
U70 is a driver directory, the driver in it can work well in winXP but can
not be installed in centOS.
And i also tried different drivers in directory 150U, C69, U300T and UD10.
They displayed
the same error.
Can you give me some advice?
Thank you very much!

2011/6/8 Drew <drew.kay at gmail.com>

> > hi,
> >    i'm woo, I'm a newer to CentOS. I installed my
> CentOS5.3(2.6.18-128.el5)
> > in VMware.
> > And my wireless card is MERCURY 54U(Atheros AR5xxx).I plugged the USB
> card
> > into my virtual machine, but it couldn't be found.
> First off. Which VMWare program are you using? There are some pretty
> big differences between the Player/Workstation/Server family and the
> ESX(i)/vSphere family of products.
> ESX you can pretty much write that idea off unless you have a newer
> system that supports Intel's VT-d (or AMD's equivalent). Player is a
> bit different if it's a usb device as you can attach to the guest a
> required.
> Assuming Player, are you *absolutely sure* that you connected the USB
> device to the guest per VMware's procedures? If yes, what's the output
> of "lsusb"? We need to know *if* it's being seen by the guest at all
> to begin with.
> --
> Drew
> "Nothing in life is to be feared. It is only to be understood."
> --Marie Curie
> "This started out as a hobby and spun horribly out of control."
> -Unknown
> _______________________________________________
> CentOS-virt mailing list
> CentOS-virt at centos.org
> http://lists.centos.org/mailman/listinfo/centos-virt
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.centos.org/pipermail/centos-virt/attachments/20110609/0914b9ef/attachment-0005.html>