[CentOS-virt] XEN multiple bridge problem - VM won' start!

Matija Draganović

mdra137 at gmail.com
Fri Nov 18 17:17:17 UTC 2011

Dear Peter,

Thanks for your reply. I was so occupied with troubleshooting that I forgot
to mention the OS & Xen version :)

My CentOS version is
CentOS release 5.7 (Final)
Linux 2.6.18-274.7.1.el5xen #1 SMP Thu Oct 20 17:06:34 EDT 2011 x86_64
x86_64 x86_64 GNU/Linux

and Xen v3.0.

I tried creating bridges the same way you did and succedded. I also tried
doing the same via ifcfg scripts, and it also worked.

I have no problem with creating bridges and connecting them with physical
ifaces, but I can't start my VM's (most of the time one VM start but the
other one hangs while trying to initalize eth2 that is connected to my
second (non default - xenbr1) bridge)).

The only diference between your config and mine is that I have vifname-s
listed (example below):

vif = [
"mac=00:16:3e:57:de:0d,bridge=xenbr1,script=vif-bridge, vifname=vif4.1" ]

I'm not saying that this could be the problem, but since I'm slowly running
out of ideas - it's a longshot :)

So, to sum it all up - I can create bridges properly, but my VM's hang when
they try to bring up vifaces connected to the xenbr1. Also, I have no
problem with having only one bridge active - problem appears when I have
multiple bridges.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.centos.org/pipermail/centos-virt/attachments/20111118/2a75ed85/attachment-0002.html>

More information about the CentOS-virt mailing list