[CentOS-virt] Having trouble starting more than 8 Xen guests

Sun Sep 18 16:13:16 UTC 2011
Scot P. Floess <sfloess at nc.rr.com>


I've spent quite a few hours trying to figure this out to no avail...  I 
have two machines and the result is the same on both.  Additionally, 
each machine does not support full hardware virtualization...

I am able to create 8 VMs.  When attempting to create ninth VM, I get the following 

Error: Device 51712 (vbd) could not be connected. /etc/xen/scripts/block 
failed; error detected.

To create the VMs, I use the command:

"xm create [vm name]"

My machine has 8 GB RAM and is an "old school" dual opteron box.

"uname -a" is:

Linux centos-host-2 2.6.18-274.3.1.el5.centos.plusxen #1 SMP Wed Sep 7 
06:25:54 EDT 2011 x86_64 x86_64 x86_64 GNU/Linux

To be clear, I can shutdown any one of the 8 VMs and then run the ninth 
"xm create" - that VM will start...

I did some google'ing and from what I cn tell that error arises due to the 
lack of loop back devices (there being 8 by default)...

I've tried both using MAKEDEV (in my /etc/rc.local) to create a number of 
loop back devices and put max_loops in my grub,.conf file.  For example 
here is what I have in grub.conf now:

title CentOS (2.6.18-274.3.1.el5.centos.plusxen)
         root (hd0,0)
         kernel /xen.gz-2.6.18-274.3.1.el5.centos.plus
         module /vmlinuz-2.6.18-274.3.1.el5.centos.plusxen ro root=LABEL=/ 
         module /initrd-2.6.18-274.3.1.el5.centos.plusxen.img

Due to wrapping, max_loop is actually on the module /vmlinuz- line...

I also tried to put max_loop on the kernel line as well...

As I mentioned above, I also created the loop back devices from 
/etc/rc.local like so:

/sbin/MAKEDEV -d /dev -m 64 loop

And, once I can log in to the machine, I do see everything in /dev (for 
example /dev/loop0 to /dev/loop64)

Has anyone else had this problem?  If so, how did you resolve it????

Thanks ahead of time!!!!!

Scot P. Floess             RHCT  (Certificate Number 605010084735240)
Chief Architect FlossWare  http://sourceforge.net/projects/flossware