[CentOS-virt] Having trouble starting more than 8 Xen guests

Mon Sep 19 17:21:48 UTC 2011
Scot P. Floess <sfloess at nc.rr.com>


That did it!  Thanks so much...  I've got 12 VMs running now...just fine 

On Mon, 19 Sep 2011, Ian Forde wrote:

> On Sep 18, 2011, at 9:13, "Scot P. Floess" <sfloess at nc.rr.com> wrote:
>> I did some google'ing and from what I cn tell that error arises due to the
>> lack of loop back devices (there being 8 by default)...
>> I've tried both using MAKEDEV (in my /etc/rc.local) to create a number of
>> loop back devices and put max_loops in my grub,.conf file.  For example
>> here is what I have in grub.conf now:
>> title CentOS (2.6.18-274.3.1.el5.centos.plusxen)
>>         root (hd0,0)
>>         kernel /xen.gz-2.6.18-274.3.1.el5.centos.plus
>>         module /vmlinuz-2.6.18-274.3.1.el5.centos.plusxen ro root=LABEL=/
>> max_loop=64
>>         module /initrd-2.6.18-274.3.1.el5.centos.plusxen.img
>> Due to wrapping, max_loop is actually on the module /vmlinuz- line...
>> I also tried to put max_loop on the kernel line as well...
>> As I mentioned above, I also created the loop back devices from
>> /etc/rc.local like so:
>> /sbin/MAKEDEV -d /dev -m 64 loop
>> And, once I can log in to the machine, I do see everything in /dev (for
>> example /dev/loop0 to /dev/loop64)
>> Has anyone else had this problem?  If so, how did you resolve it????
> Actually, you have max_loops=64 in the wrong file.  You want it in /etc/modprobe.conf as thus:
> options loop max_loop=64
> Once that is in, a reboot (after shutting down the running VMs) is the quickest way to activate it.  Take the makedev and grub stuff out...
>  -I
> _______________________________________________
> CentOS-virt mailing list
> CentOS-virt at centos.org
> http://lists.centos.org/mailman/listinfo/centos-virt

Scot P. Floess             RHCT  (Certificate Number 605010084735240)
Chief Architect FlossWare  http://sourceforge.net/projects/flossware