[CentOS-virt] PXE boot of KVM virtual fails

Tue Jul 10 19:52:24 UTC 2012
centos <centos at martin1975.force9.co.uk>

Hi, excuse me if I make any faux-pas this is the first time I've posted 
to a list. Can someone confirm that it is possible to PXE boot a KVM 
virtual machine from another KVM virtual machine?

I have a virtual x86_64 Centos 6.2 server running DHCP and TFTP. The 
plan is to kickstart a new KVM machine - purely so I can get my head 
around PXE and kickstart (I've not used either before).

 From the output I'm seeing it would appear that the DHCP is working ok, 
and that the boot loader (pxelinux.0) is being sent via TFTP, but then 
I'm seeing a couple of errors. Firstly I get... 
tftp:// Not supported (0x3c126003) then I 
get.... Could not load tftp:// Not supported 
(0x3c126003) No more network devices.

I have a feeling that this is indicating that the PXE boot loader 
(pxelinux.0) isn't compatible with the virtual network card - I've tried 
most of the NICs available, and I've tried gpxelinux.0 and some of the 
files provided by gpxe-roms-qemu (though I have to admit I'm not sure if 
I need to do something with those files to make them boot loaders?).

My biggest worry is that I'm trying to do something nonsensical, but if 
not - has anyone managed to get this to work?