[CentOS-virt] How do boot a xen domu into run level 1

Thu Sep 20 16:16:50 UTC 2012
Kevin Coleman <kevin.coleman at laser2mail.com>

I am using pygrub to boot and this is how I got it to work:

  xm create -c <path to >dev3.cfg

at the boot splash select the kernel you are using to boot with..
press e to edit.
press e and edit the kernel line and put single right after the kernel 

i.e.   kernel /vmlinuz-2.6.18-274.3.1.el5xen single ro 
root=/dev/VolGroup00/LogVol00 .....
press enter to save your change.
It will return back to the  boot option menu

     pyGRUB  version 0.6
  ? kernel /vmlinuz-2.6.18-274.3.1.el5xen single ro 
root=/dev/VolGroup00/>               ?
  ? initrd /initrd-2.6.18-274.3.1.el5xen.img          ?
  ? ?
  ? ?
  ? ?
  ? ?
  ? ?
  ? ?
      Use the ^ and v keys to select which entry is highlighted.
      Press 'b' to boot, 'e' to edit the selected command in the
      boot sequence, 'c' for a command-line, 'o' to open a new line
      after ('O' for before) the selected line, 'd' to remove the
      selected line, or escape to go back to the main menu.

hit b to boot...

it worked for me a couple of times in succession.

Good luck.


Kevin Coleman - Network Engineer
kevin.coleman at laser2mail.com

On 09/20/2012 10:48 AM, Ed Heron wrote:
>    You could loop mount the messed up disk on the host or you could mount
> the messed up disk on another DomU and change it.
> On Thu, 2012-09-20 at 08:58 -0400, me at tdiehl.org wrote:
>> Hi,
>> I have a C5.8 machine with several DomU's. I fubared the fstab on one of them
>> and I need to get it into single user mode.
>> Does anyone know how to do that? I tried adding single to the extras line
>> in /etc/xen/machine_name but it still tries to start in level 3.
>> To make things worse, the root partition is on LVM.
>> Alternatively, does anyone know how to access the image from DomU? I tried
>> to use kpartx but when I run VGscan, I do not get the lvm activated.
>> Regards,
> _______________________________________________
> CentOS-virt mailing list
> CentOS-virt at centos.org
> http://lists.centos.org/mailman/listinfo/centos-virt

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.centos.org/pipermail/centos-virt/attachments/20120920/5acb095a/attachment-0006.html>