[CentOS-virt] Xen4CentOS installation strangeness

Fri Mar 14 14:38:58 UTC 2014
Peter Peltonen <peter.peltonen at gmail.com>


On Tue, Mar 4, 2014 at 10:08 PM, Robert Dinse <nanook at eskimo.com> wrote:

>      I'd look in the logs for Xorg failures.

Thanks Robert, it seems Xorg is indeed the one to blame in this case.
Apparently the network issues I experienced at the same time were just bad
luck and not related, so while booting another time I could SSH into the

These errors are visible in the Xorg logs:


[   128.186] (EE)

[   128.186] (EE) Backtrace:

[   128.186] (EE) 0: X (xorg_backtrace+0x36) [0x46d196]

[   128.186] (EE) 1: X (0x400000+0x72f99) [0x472f99]

[   128.186] (EE) 2: /lib64/libpthread.so.0 (0x7fb7b6fa3000+0xf710)

[   128.186] (EE) 3: /usr/lib64/xorg/modules/drivers/xgi_drv.so
(0x7fb7b4459000+0x21a95) [0x7fb7b447aa95]

[   128.186] (EE) 4: /usr/lib64/xorg/modules/drivers/xgi_drv.so
(0x7fb7b4459000+0x23159) [0x7fb7b447c159]

[   128.186] (EE) 5: X (dixSaveScreens+0x15e) [0x4695ee]

[   128.186] (EE) 6: X (0x400000+0x7d061) [0x47d061]

[   128.186] (EE) 7: /lib64/libc.so.6 (__libc_start_main+0xfd)

[   128.187] (EE) 8: X (0x400000+0x26189) [0x426189]

[   128.187] (EE)

[   128.187] (EE) Segmentation fault at address 0x0

[   128.187]

Fatal server error:

[   128.187] Caught signal 11 (Segmentation fault). Server aborting

[   128.187]

[   128.187] (EE)

Please consult the CentOS support


Some more googling revealed that other people have had similar problems.
This is most likely caused by either Xen or the new Xen enabled kernel that
was installed as with stock CentOS6 kernel it is not happening. I ran some
hardware diagnostics tests for the motherboard and CPUs which passed ok.

I tried creating a new Xorg configuration file and starting X with that,
but it did not help. Changing the server's runlevel to 3 resulted the
server to boot ok in non-graphical mode. As I can run virt-manager
remotely, there is no reason for me to debug this further, and I just
wanted to report the issues I've experienced here on the list.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.centos.org/pipermail/centos-virt/attachments/20140314/dd328fbb/attachment-0004.html>