[CentOS-virt] win2008r2 update on centos 6 host made system unbootable

Wed Dec 9 09:04:26 UTC 2015
Nux! <nux at li.nux.ro>

This is pretty epic if true.
I'm installing some Fail 2008r2 now to check.

Is your hypervisor running CentOS 6 or 7?

Sent from the Delta quadrant using Borg technology!


----- Original Message -----
> From: "Dennis Jacobfeuerborn" <dennisml at conversis.de>
> To: "Discussion about the virtualization on CentOS" <centos-virt at centos.org>
> Sent: Wednesday, 9 December, 2015 00:00:28
> Subject: Re: [CentOS-virt] win2008r2 update on centos 6 host made system unbootable

> On 09.12.2015 00:39, NightLightHosts Admin wrote:
>> On Tue, Dec 8, 2015 at 5:26 PM, Dennis Jacobfeuerborn
>> <dennisml at conversis.de> wrote:
>>> Hi,
>>> today we ran into a strange problem: When performing a regular Windows
>>> 2008r2 update apparently among other things the following was installed:
>>> "SUSE - Storage Controller - SUSE Block Driver for Windows"
>>> Previously the disk drive was using the Red Hat virtio drivers which
>>> worked just fine but after the reboot after the update I just get a blue
>>> screen indicating that Windows cannot find a boot device.
>>> Does anyone understand what is going on here? Why is the windows update
>>> installing a Suse driver that overrides the Red Hat driver even though
>>> it is apparently incompatible with the system?
>>> Regards,
>>>   Dennis
>> Did you roll back the driver and did it work after that?
> I can't roll back the driver for that device because I can't boot the
> system. The only way I can boot into the system is by changing the disk
> type to IDE but then I cannot roll back the driver because the entire
> device changed. As far as I can tell the Suse version of the virtio
> block driver is incompatible with the incompatible with the system but
> right now I see no way to tell windows "Uninstall the driver completely
> for the entire system" so that on the next boot it would fall back to
> the old virtio driver from Red Hat.
> I tried installing the current stable drivers from this URL:
> https://fedoraproject.org/wiki/Windows_Virtio_Drivers
> But Windows refuses and says the driver is already up-to-date.
> What worries me is that I want to update other win2008r2 guests as well
> but now fear that they will all be rendered unbootable by such an update.
> Regards,
>  Dennis
> _______________________________________________
> CentOS-virt mailing list
> CentOS-virt at centos.org
> https://lists.centos.org/mailman/listinfo/centos-virt