[CentOS-virt] [CentOS] boot thumbdrive with CentOS 7 ISO???

Mon Dec 14 09:30:08 UTC 2015
ken <gebser at mousecar.com>

On 12/13/2015 05:00 PM, Frank Cox wrote:
> On Sun, 13 Dec 2015 16:48:25 -0500 ken wrote:
>> So far I've created on this new laptop a big, empty partition; in
>> the BIOS enabled legacy booting and disabled UEFI; also in BIOS
>> under Legacy Boot Order set "USB diskette on key/USB hard disk" on
>> second priority. I've tried to boot from a usb thumbdrive three
>> times and it failed all three times.  I'm not understanding what's
>> wrong.
> I install Centos on pretty much everything by setting the bios to use
> USB as the primary boot device, then booting the Centos Live Image
> from a flash drive, then hitting the "install to hard drive" icon on
> the Live Desktop.  After the installation is complete, set the bios
> back to use the hard drive as the primary boot device and you're all
> set.

Aha!  The problem was that, despite legacy was enabled and uefi was 
disabled, the bios followed 'uefi boot order' and disregarded 'legacy 
boot order'.  Once I changed uefi boot order appropriately, the  bios 
booted the thumbdrive.

However, when the centos menu came up, i.e.:

Install CentOS 7
Test this media & install CentOS 7
Troubleshooting -->

[use 'e' or 'c' keys]

regardless of which of the above three I selected via right-arrow, I was 
prompted by:

error: invalid magic number.
error: you need to load the kernel first.
Press any key to continue...

I tried also using the 'e' and 'c' keys off this menu; this brought into 
other menus (which are too much to type up) and on another menu where ^E 
and ^X can be used to 'edit' and 'execute' boot statements, none of 
which works correctly or is obvious what to alter or enter.

I also got into an interface with a 'grub>' prompt.  I tried some of the 
grub commands, but had little clue what to do with that.  E.g., 
"linuxefi /isolinux/isolinux.bin" returned "error: invalid magic 
number."  Interesting, but not getting CentOS 7 booted.

Any know what else is possible?