[CentOS-virt] Libvirt enhancement requests

Johnny Hughes johnny at centos.org
Wed Nov 4 11:19:30 UTC 2015


On 11/04/2015 04:31 AM, Jean-Marc LIGER wrote:
> 
> 
> Le 03/11/2015 00:49, Jean-Marc LIGER a écrit :
>>
>> Le 02/11/2015 18:28, Johnny Hughes a écrit :
>>> On 10/31/2015 04:34 PM, Jean-Marc LIGER wrote:
>>>> Hi Lucian,
>>>>
>>>> It seems to be upstream libvirt-1.2.15-2 with options with_xen and
>>>> with_libxl enabled.
>>>> http://cbs.centos.org/koji/buildinfo?buildID=1348
>>>>
>>> Right, and we can use that version, or a newer one and enable rbd as well.
>>
>> You might use this preview one :
>> http://people.redhat.com/~rjones/libguestfs-RHEL-7.2-preview/libvirt-1.2.17-3.el7.src.rpm
>>
>> I personally rebuild libvirt from last official releases which enable
>> ceph by default for el7 :
>> http://libvirt.org/sources/
>>
>> My dogfooding tests still **can be found here :
>> https://copr.fedoraproject.org/coprs/jmliger/virt7-upstream/
>>
>>> The next question is, is there a difference between the generic rbd and
>>> building against ceph-devel.  (As in, is one ceph only and the other
>>> generic only or can you use both when built against ceph-devel, etc)
>>>
>>> Since qemu-kvm-ev enables ceph, if we can also enable ceph in libvirt,
>>> seems like a win to me, if it also does rbd the same as building against
>>> librados2-devel and librbd1-devel.
>> Maybe I'm wrong but ceph-devel seems to have been replaced by librados2-devel and librbd1-devel in el7.
> 
> %package devel-compat
> Summary:        Compatibility package for Ceph headers
> Group:          Development/Libraries
> License:        LGPL-2.0
> Obsoletes:      ceph-devel
> Requires:       %{name} = %{epoch}:%{version}-%{release}
> Requires:       librados2-devel = %{epoch}:%{version}-%{release}
> Requires:       libradosstriper1-devel = %{epoch}:%{version}-%{release}
> Requires:       librbd1-devel = %{epoch}:%{version}-%{release}
> Requires:       libcephfs1-devel = %{epoch}:%{version}-%{release}
> Requires:       libcephfs_jni1-devel = %{epoch}:%{version}-%{release}
> Provides:       ceph-devel
> %description devel-compat
> This is a compatibility package to accommodate ceph-devel split into
> librados2-devel, librbd1-devel and libcephfs1-devel. Packages still
> depending
> on ceph-devel should be fixed to depend on librados2-devel, librbd1-devel,
> libcephfs1-devel or libradosstriper1-devel instead.
> 

I concur that the spec file uses that the way it is written.  What I
wonder is *IF* one wants to use ceph specifically, then are libvirt
packages built against librados2-devel and librbd1-devel going to work
then as well?

I do concur that it seems in the beta for rhel-7.2 this all gets
resolved for 7.2.  Since that should be happening soon(ish) .. based on
previous release history, we should wait and see exactly what is in 7.2
when released.

We also need to test that with ceph community packages to see if rbd
built that way actually works with ceph as well.

>>> These may only work with CentOS 7 as well .. have to look at if those
>>> build in CentOS 6.7.
>>
>> Which ceph release forCentOS 6.7Hammer or Firefly ?
>> Jean-Marc Liger
>>


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 198 bytes
Desc: OpenPGP digital signature
URL: <http://lists.centos.org/pipermail/centos-virt/attachments/20151104/6c2f4df9/attachment.sig>


More information about the CentOS-virt mailing list