[CentOS-virt] new install of Xen 4.6 hangs on Loading initial ramdisk

Mon Nov 30 11:00:19 UTC 2015
George Dunlap <dunlapg at umich.edu>

On Fri, Nov 27, 2015 at 11:18 PM, Craig Thompson <
president at caldwellglobal.com> wrote:

> First post to this list.  I would appreciate some help on this issue.
> As background, I installed CentOS 7 on a Dell server, and then ran the
> following commands:
> yum update
> http://buildlogs.centos.org/centos/7/virt/x86_64/xen/centos-release-xen-7-11.el7.x86_64.rpm
> yum --enablerepo=centos-virt-xen-testing update
> yum --enablerepo=centos-virt-xen-testing install xen
> Doing that, I was able to successfully install Xen, create a virtual
> machine with its own HVM setup, logical volume, etc. and boot it just fine.
> I then tried to do the same on an IBM x3550 server I’m trying to install
> with CentOS 7.  The CentOS 7 install went just fine.  I can boot into the
> standard kernel and have a working machine.  But after running the commands
> above to install the Xen hypervisor, the machine hangs on boot for a few
> moments after displaying the lines below and then reboots in a loop over
> and over and over:
> Loading Xen 4.6.0-2.el7 …
> Loading Linux 3.18.21-16.el7.x86_64 …
> Loading initial ramdisk …
> It never gets beyond that.  If I choose the stock kernel (no Xen) from the
> Grub menu, it will continue to boot into that just fine.
> My grub.cfg file has these entries of note:
>  multiboot /xen-4.6.0-2.el7.gz placeholder  dom0_mem=1024M,max:1024M
> cpuinfo com1=115200,8n1 console=com1,tty loglvl=all guest_loglvl=all
> ${xen_rm_opts}
>         echo    'Loading Linux 3.18.21-16.el7.x86_64 ...'
>         module  /vmlinuz-3.18.21-16.el7.x86_64 placeholder
> root=UUID=9dc18146-f9b3-41cc-ba9c-7314689abcde ro crashkernel=auto debug
> irqpoll ipv6.disable=1 console=hvc0 earlyprintk=xen nomodeset
>         echo    'Loading initial ramdisk ...'
>         module  --nounzip   /initramfs-3.18.21-16.el7.x86_64.img
> What I have tried:
> 1) adding debug into the vmlinuz line
> 2) disabling ipv6 in that line
> 3) adding root=UUID=9dc18146-f9b3-41cc-ba9c-7314689abcde to the last line
> AFTER /initramfs ….
> Nothing so far has made any difference.  Obviously the process works, as
> it works for me just fine on the Dell server.
> Underlying this machine is a SATA RAID 1 PCI card with two SSD drives
> attached in a RAID 1 mirror.  Not that that should matter, but I’m
> including it for reference. As noted previously, it boots into the stock
> kernel just fine.
> Any help would be appreciated.

Thanks for the testing and the report.

Have you tried booting the Xen4CentOS kernel (Linux-3.18.21-16) by itself
(i.e., not under Xen)?

Also, is there any chance you could get the output of a serial console?
That's pretty critical for debugging this sort of thing.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.centos.org/pipermail/centos-virt/attachments/20151130/40d5fa34/attachment-0006.html>