[CentOS-virt] CentOS 7 Xen 4.4.3 packages available for in virt7-xen-44-testing

Tue Sep 22 11:08:12 UTC 2015
George Dunlap <dunlapg at umich.edu>

On Mon, Sep 21, 2015 at 4:18 PM, Pasi Kärkkäinen <pasik at iki.fi> wrote:
> On Mon, Sep 21, 2015 at 01:46:36PM +0300, Pasi Kärkkäinen wrote:
>> OK. I can now see the libvirt 1.2.15-3.el7 rpms in the virt7-xen-44-testing repo,
>> but it seems yum still doesn't pick them up:
>> # yum clean all
>> # yum --enablerepo=virt-xen-44-testing update
>> ..
>> No packages marked for update
>> # rpm -qa | grep -i libvirt-daemon-1
>> libvirt-daemon-1.2.8-16.el7_1.4.x86_64
>> I guess I'll install those 1.2.15-3.el7 rpms manually.
> It seems now the packages installed OK using yum aswell. I guess you or someone refreshed the repo :)

Updating the repos isn't actually triggered -- there's a script that
runs every 10 minutes.  So if you get old data, try again in 10
minutes or so. :-)

> Anyway, here's something I noticed while testing xend bits:
> # systemctl enable xend.service
> xend.service is not a native service, redirecting to /sbin/chkconfig.
> Executing /sbin/chkconfig xend on
> The unit files have no [Install] section. They are not meant to be enabled
> using systemctl.
> Possible reasons for having this kind of units are:
> 1) A unit may be statically enabled by being symlinked from another unit's
>    .wants/ or .requires/ directory.
> 2) A unit's purpose may be to act as a helper for some other unit which has
>    a requirement dependency on it.
> 3) A unit may be started when needed via activation (socket, path, timer,
>    D-Bus, udev, scripted systemctl call, ...).
> "systemctl start xend.service" works OK though.. and after that xm works too.

Right -- I haven't tried xend under systemd.  Given that xend is gone
in 4.6, I'm considering whether to say "patches welcome" re fixing
xend in 4.4 for C7...