[CentOS-virt] unable to execute QEMU command 'migrate': this feature or command is not currently supported

Wed Mar 22 13:40:26 UTC 2017
-=X.L.O.R.D=- <xlord.sl at gmail.com>

Hum..if the live migration is not happening on a shared storage, then I
think it is best to have offline migration copy to image and hook up to the
destinated server instead, this is a short-cut path I suppose.


-----Original Message-----
From: CentOS-virt [mailto:centos-virt-bounces at centos.org] On Behalf Of
Valentin Guggiana
Sent: Monday, March 20, 2017 8:47 PM
To: Discussion about the virtualization on CentOS <centos-virt at centos.org>;
'Paolo Bonzini' <pbonzini at redhat.com>
Subject: Re: [CentOS-virt] unable to execute QEMU command 'migrate': this
feature or command is not currently supported

Dear Xlord

> Please check if the VM guest has vm-tools installed else the "virsh 
> migrate --live" parameter requirement is not fulfilled else you has to 
> turn off the VM guest and do the offline "virsh migrate" without 
> "--live" options. Hope that helps.

As far as I know (and it definitely worked in CentOS 6 and from CentOS 6 to
CentOS 7) no guest tools are needed. But I tried it nevertheless:
did not work :(

Live migration with shared storage works fine but in my case I need to do
live migrations without shared storage (in order to free running hosts to
upgrade their OSes and setup shared storage)

I suspect either that the qemu-kvm binary from qemu-kvm-ev-2.6.0-28 is
missing this feature or it is called without a needed option. Comparing
running qemu-kvm processes on CentOS 6 and CentOS 7 I can see that those on
CentOS 6 have -enable-kvm on the command lime but those on CentOS 7 have

How can the qemu-kvm binary be checked to see if the feature is enabled?

Thanks, Valentin
CentOS-virt mailing list
CentOS-virt at centos.org