[CentOS-virt] TPM

Wed Aug 29 07:00:39 UTC 2018
Sandro Bonazzola <sbonazzo at redhat.com>

2018-08-28 13:52 GMT+02:00 Dag Nygren <dag at newtech.fi>:

> Hi all!
> Just setting up a cluster using Centos 7
> We have a desperate need for TPM support and:
> 1. Tried the "standard" distro install. linvirt supports
>   TPM passthrough but kvm-qemu barfs:
>   "unsupported configuration: The QEMU executable /usr/libexec/qemu-kvm
> does not support TPM backend type passthrough"
> 2. The activated the qemu-ev repo and updated qemu-kvm to version 2.10.0,
> which for sure
>    should support at least passthrough. No luck - Same error message.
>    Downloaded the source for th rpm and found a line: "--disable-tpm"
>    in build_configure.sh. Guess that the maintainers has some reason
>    to turn tpm off. Can somone confirm this?

Not sure about reasons for turning off, but request to enable it has been
closed wontfix: https://bugzilla.redhat.com/show_bug.cgi?id=1327947

> 3. And now what next? The setup would really need swtpm, which
>    should be available in 2.11.0. Can someone confirm that tpm
>    will be enabled here? Would also be nice having a libvirt that
>    will accept the swtpm configuration. the current don't like it.

Adding Miroslav

> Could of course recompile qemu myself, but really wouldn't like
> going that route. The sheer number of patches applied is quite scary...
> Best
> Dag
> _______________________________________________
> CentOS-virt mailing list
> CentOS-virt at centos.org
> https://lists.centos.org/mailman/listinfo/centos-virt




Red Hat EMEA <https://www.redhat.com/>

sbonazzo at redhat.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.centos.org/pipermail/centos-virt/attachments/20180829/a27232bf/attachment-0006.html>