[CentOS-virt] Upgrade to CentOS 7.6 with centos-xen-48 enabled

Gennardy Smith lists at mistrust.net
Sun Dec 23 10:01:01 UTC 2018


Hi all,

I'm unable to upgrade my Dom-0 from CentOS 7.5 to CentOS 7.6 with the 
sigvirt
centos-xen-48 repository enabled and Xen components enabled.

It breaks down to down to the fact that 7.6 has a newer version of libvirt
included (4.5), while the Xen repository's packages are build against 4.1
version of libvirt.

I also tried to enable the libvirt-latest repository, but that does not
contain libvirt-daemon-driver-xen package, so dependency resolution is
broken again.

Is there some workaround for this, or do I just have to wait for the Xen
repository to be updated? Has someone resolved this problem?

Regards,
G.

The following is the output of yum when running yum update:

[user at dom0 ~]$ sudo yum update
[...]
--> Finished Dependency Resolution
Error: Package: libvirt-daemon-driver-xen-4.1.0-2.xen48.el7.x86_64 
(@centos-virt-xen-48)
            Requires: libvirt.so.0(LIBVIRT_PRIVATE_4.1.0)(64bit)
            Removing: libvirt-libs-4.1.0-2.xen48.el7.x86_64 
(@centos-virt-xen-48)
                libvirt.so.0(LIBVIRT_PRIVATE_4.1.0)(64bit)
            Updated By: libvirt-libs-4.5.0-10.el7_6.3.x86_64 (updates)
               ~libvirt.so.0(LIBVIRT_PRIVATE_4.5.0)(64bit)
Error: Package: libvirt-daemon-driver-libxl-4.1.0-2.xen48.el7.x86_64 
(@centos-virt-xen-48)
            Requires: libvirt.so.0(LIBVIRT_PRIVATE_4.1.0)(64bit)
            Removing: libvirt-libs-4.1.0-2.xen48.el7.x86_64 
(@centos-virt-xen-48)
                libvirt.so.0(LIBVIRT_PRIVATE_4.1.0)(64bit)
            Updated By: libvirt-libs-4.5.0-10.el7_6.3.x86_64 (updates)
               ~libvirt.so.0(LIBVIRT_PRIVATE_4.5.0)(64bit)
Error: Package: libvirt-daemon-xen-4.1.0-2.xen48.el7.x86_64 
(@centos-virt-xen-48)
            Requires: libvirt-daemon-driver-network = 4.1.0-2.xen48.el7
            Removing: 
libvirt-daemon-driver-network-4.1.0-2.xen48.el7.x86_64 (@centos-virt-xen-48)
                libvirt-daemon-driver-network = 4.1.0-2.xen48.el7
            Updated By: 
libvirt-daemon-driver-network-4.5.0-10.el7_6.3.x86_64 (updates)
                libvirt-daemon-driver-network = 4.5.0-10.el7_6.3
            Available: 
libvirt-daemon-driver-network-3.2.1-480.el7.x86_64 (centos-virt-xen-48)
                libvirt-daemon-driver-network = 3.2.1-480.el7
            Available: libvirt-daemon-driver-network-4.5.0-10.el7.x86_64 
(base)
                libvirt-daemon-driver-network = 4.5.0-10.el7
            Available: 
libvirt-daemon-driver-network-4.5.0-10.el7_6.2.x86_64 (updates)
                libvirt-daemon-driver-network = 4.5.0-10.el7_6.2
Error: Package: libvirt-daemon-driver-xen-4.1.0-2.xen48.el7.x86_64 
(@centos-virt-xen-48)
            Requires: libvirt-daemon = 4.1.0-2.xen48.el7
            Removing: libvirt-daemon-4.1.0-2.xen48.el7.x86_64 
(@centos-virt-xen-48)
                libvirt-daemon = 4.1.0-2.xen48.el7
            Updated By: libvirt-daemon-4.5.0-10.el7_6.3.x86_64 (updates)
                libvirt-daemon = 4.5.0-10.el7_6.3
            Available: libvirt-daemon-3.2.1-480.el7.x86_64 
(centos-virt-xen-48)
                libvirt-daemon = 3.2.1-480.el7
            Available: libvirt-daemon-4.5.0-10.el7.x86_64 (base)
                libvirt-daemon = 4.5.0-10.el7
            Available: libvirt-daemon-4.5.0-10.el7_6.2.x86_64 (updates)
                libvirt-daemon = 4.5.0-10.el7_6.2
Error: Package: libvirt-daemon-xen-4.1.0-2.xen48.el7.x86_64 
(@centos-virt-xen-48)
            Requires: libvirt-daemon-driver-nwfilter = 4.1.0-2.xen48.el7
            Removing: 
libvirt-daemon-driver-nwfilter-4.1.0-2.xen48.el7.x86_64 
(@centos-virt-xen-48)
                libvirt-daemon-driver-nwfilter = 4.1.0-2.xen48.el7
            Updated By: 
libvirt-daemon-driver-nwfilter-4.5.0-10.el7_6.3.x86_64 (updates)
                libvirt-daemon-driver-nwfilter = 4.5.0-10.el7_6.3
            Available: 
libvirt-daemon-driver-nwfilter-3.2.1-480.el7.x86_64 (centos-virt-xen-48)
                libvirt-daemon-driver-nwfilter = 3.2.1-480.el7
            Available: 
libvirt-daemon-driver-nwfilter-4.5.0-10.el7.x86_64 (base)
                libvirt-daemon-driver-nwfilter = 4.5.0-10.el7
            Available: 
libvirt-daemon-driver-nwfilter-4.5.0-10.el7_6.2.x86_64 (updates)
                libvirt-daemon-driver-nwfilter = 4.5.0-10.el7_6.2
Error: Package: libvirt-daemon-xen-4.1.0-2.xen48.el7.x86_64 
(@centos-virt-xen-48)
            Requires: libvirt-daemon-driver-storage = 4.1.0-2.xen48.el7
            Removing: 
libvirt-daemon-driver-storage-4.1.0-2.xen48.el7.x86_64 (@centos-virt-xen-48)
                libvirt-daemon-driver-storage = 4.1.0-2.xen48.el7
            Updated By: 
libvirt-daemon-driver-storage-4.5.0-10.el7_6.3.x86_64 (updates)
                libvirt-daemon-driver-storage = 4.5.0-10.el7_6.3
            Available: 
libvirt-daemon-driver-storage-3.2.1-480.el7.x86_64 (centos-virt-xen-48)
                libvirt-daemon-driver-storage = 3.2.1-480.el7
            Available: libvirt-daemon-driver-storage-4.5.0-10.el7.x86_64 
(base)
                libvirt-daemon-driver-storage = 4.5.0-10.el7
            Available: 
libvirt-daemon-driver-storage-4.5.0-10.el7_6.2.x86_64 (updates)
                libvirt-daemon-driver-storage = 4.5.0-10.el7_6.2
Error: Package: libvirt-daemon-xen-4.1.0-2.xen48.el7.x86_64 
(@centos-virt-xen-48)
            Requires: libvirt-daemon-driver-interface = 4.1.0-2.xen48.el7
            Removing: 
libvirt-daemon-driver-interface-4.1.0-2.xen48.el7.x86_64 
(@centos-virt-xen-48)
                libvirt-daemon-driver-interface = 4.1.0-2.xen48.el7
            Updated By: 
libvirt-daemon-driver-interface-4.5.0-10.el7_6.3.x86_64 (updates)
                libvirt-daemon-driver-interface = 4.5.0-10.el7_6.3
            Available: 
libvirt-daemon-driver-interface-3.2.1-480.el7.x86_64 (centos-virt-xen-48)
                libvirt-daemon-driver-interface = 3.2.1-480.el7
            Available: 
libvirt-daemon-driver-interface-4.5.0-10.el7.x86_64 (base)
                libvirt-daemon-driver-interface = 4.5.0-10.el7
            Available: 
libvirt-daemon-driver-interface-4.5.0-10.el7_6.2.x86_64 (updates)
                libvirt-daemon-driver-interface = 4.5.0-10.el7_6.2
Error: Package: libvirt-daemon-xen-4.1.0-2.xen48.el7.x86_64 
(@centos-virt-xen-48)
            Requires: libvirt-daemon-driver-secret = 4.1.0-2.xen48.el7
            Removing: 
libvirt-daemon-driver-secret-4.1.0-2.xen48.el7.x86_64 (@centos-virt-xen-48)
                libvirt-daemon-driver-secret = 4.1.0-2.xen48.el7
            Updated By: 
libvirt-daemon-driver-secret-4.5.0-10.el7_6.3.x86_64 (updates)
                libvirt-daemon-driver-secret = 4.5.0-10.el7_6.3
            Available: libvirt-daemon-driver-secret-3.2.1-480.el7.x86_64 
(centos-virt-xen-48)
                libvirt-daemon-driver-secret = 3.2.1-480.el7
            Available: libvirt-daemon-driver-secret-4.5.0-10.el7.x86_64 
(base)
                libvirt-daemon-driver-secret = 4.5.0-10.el7
            Available: 
libvirt-daemon-driver-secret-4.5.0-10.el7_6.2.x86_64 (updates)
                libvirt-daemon-driver-secret = 4.5.0-10.el7_6.2
Error: Package: libvirt-daemon-xen-4.1.0-2.xen48.el7.x86_64 
(@centos-virt-xen-48)
            Requires: libvirt-daemon = 4.1.0-2.xen48.el7
            Removing: libvirt-daemon-4.1.0-2.xen48.el7.x86_64 
(@centos-virt-xen-48)
                libvirt-daemon = 4.1.0-2.xen48.el7
            Updated By: libvirt-daemon-4.5.0-10.el7_6.3.x86_64 (updates)
                libvirt-daemon = 4.5.0-10.el7_6.3
            Available: libvirt-daemon-3.2.1-480.el7.x86_64 
(centos-virt-xen-48)
                libvirt-daemon = 3.2.1-480.el7
            Available: libvirt-daemon-4.5.0-10.el7.x86_64 (base)
                libvirt-daemon = 4.5.0-10.el7
            Available: libvirt-daemon-4.5.0-10.el7_6.2.x86_64 (updates)
                libvirt-daemon = 4.5.0-10.el7_6.2
Error: Package: libvirt-daemon-xen-4.1.0-2.xen48.el7.x86_64 
(@centos-virt-xen-48)
            Requires: libvirt-daemon-driver-nodedev = 4.1.0-2.xen48.el7
            Removing: 
libvirt-daemon-driver-nodedev-4.1.0-2.xen48.el7.x86_64 (@centos-virt-xen-48)
                libvirt-daemon-driver-nodedev = 4.1.0-2.xen48.el7
            Updated By: 
libvirt-daemon-driver-nodedev-4.5.0-10.el7_6.3.x86_64 (updates)
                libvirt-daemon-driver-nodedev = 4.5.0-10.el7_6.3
            Available: 
libvirt-daemon-driver-nodedev-3.2.1-480.el7.x86_64 (centos-virt-xen-48)
                libvirt-daemon-driver-nodedev = 3.2.1-480.el7
            Available: libvirt-daemon-driver-nodedev-4.5.0-10.el7.x86_64 
(base)
                libvirt-daemon-driver-nodedev = 4.5.0-10.el7
            Available: 
libvirt-daemon-driver-nodedev-4.5.0-10.el7_6.2.x86_64 (updates)
                libvirt-daemon-driver-nodedev = 4.5.0-10.el7_6.2
Error: Package: libvirt-daemon-driver-libxl-4.1.0-2.xen48.el7.x86_64 
(@centos-virt-xen-48)
            Requires: libvirt-daemon = 4.1.0-2.xen48.el7
            Removing: libvirt-daemon-4.1.0-2.xen48.el7.x86_64 
(@centos-virt-xen-48)
                libvirt-daemon = 4.1.0-2.xen48.el7
            Updated By: libvirt-daemon-4.5.0-10.el7_6.3.x86_64 (updates)
                libvirt-daemon = 4.5.0-10.el7_6.3
            Available: libvirt-daemon-3.2.1-480.el7.x86_64 
(centos-virt-xen-48)
                libvirt-daemon = 3.2.1-480.el7
            Available: libvirt-daemon-4.5.0-10.el7.x86_64 (base)
                libvirt-daemon = 4.5.0-10.el7
            Available: libvirt-daemon-4.5.0-10.el7_6.2.x86_64 (updates)
                libvirt-daemon = 4.5.0-10.el7_6.2
  You could try using --skip-broken to work around the problem
  You could try running: rpm -Va --nofiles --nodigest
[user at dom0 ~]$



More information about the CentOS-virt mailing list