[CentOS-virt] libvirt and libvirt-daemon-xen: failing dependencies

Frank Sauerburger frank at sauerburger.com
Thu May 17 18:57:45 UTC 2018


Hi all,

I'm trying to install libvirt for xen on a brand new, minimal
installation of CentOS 7.5.1804. After installing the OS, I did a 'yum
update' and followed the basic how-tos at

    https://wiki.centos.org/HowTos/Xen/Xen4QuickStart

and

    https://wiki.centos.org/HowTos/Xen/Xen4QuickStart/Xen4Libvirt

From previous experience, I know that the above steps worked fine.
However, now on CentOS 7.5, I am seeing the dependency resolution failing.

$ yum install libvirt libvirt-daemon-xen
[ ... ]
Error: Package: libvirt-daemon-xen-3.2.1-402.el7.x86_64 (centos-virt-xen-46)
           Requires: libvirt-daemon-driver-nwfilter = 3.2.1-402.el7
           Available:
libvirt-daemon-driver-nwfilter-3.2.1-402.el7.x86_64 (centos-virt-xen-46)
               libvirt-daemon-driver-nwfilter = 3.2.1-402.el7
           Available: libvirt-daemon-driver-nwfilter-3.9.0-14.el7.x86_64
(base)
               libvirt-daemon-driver-nwfilter = 3.9.0-14.el7
           Installing:
libvirt-daemon-driver-nwfilter-3.9.0-14.el7_5.2.x86_64 (updates)
               libvirt-daemon-driver-nwfilter = 3.9.0-14.el7_5.2
Error: Package: libvirt-daemon-driver-libxl-3.2.1-402.el7.x86_64
(centos-virt-xen-46)
           Requires: libvirt-daemon = 3.2.1-402.el7
           Available: libvirt-daemon-3.2.1-402.el7.x86_64
(centos-virt-xen-46)
               libvirt-daemon = 3.2.1-402.el7
           Available: libvirt-daemon-3.9.0-14.el7.x86_64 (base)
               libvirt-daemon = 3.9.0-14.el7
           Installing: libvirt-daemon-3.9.0-14.el7_5.2.x86_64 (updates)
               libvirt-daemon = 3.9.0-14.el7_5.2

[ ... similar errors ... ]
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

I've never seen an error like this before. As far as I read it,
libvirt-daemon-xen wants version 3.2.1 of its dependencies. I've checked
the repositories and it seems that in 'base' and 'updates' we have
version 3.9.0 and in the 'virt' repo we have 3.2.1 of libvirt. Can I
solve this issue on my end? Should I force yum to install the packages
from the 'virt' repo?

Cheers,
Frank

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 836 bytes
Desc: OpenPGP digital signature
URL: <http://lists.centos.org/pipermail/centos-virt/attachments/20180517/1c718f1f/attachment.sig>


More information about the CentOS-virt mailing list