[CentOS-virt] CentOS 8 Install as DOMU in PV Environment

Chris Wik

chris at anu.net
Sat Sep 19 17:26:41 UTC 2020

We tried to get CentOS 8 domU working in PV mode as well but did not have any success and ended up deploying it in HVM mode.

The reason OP have was lack of hardware support for HVM. This wasn't our rationale for wanting to run in PV mode. Our rationale was that we prefer to deploy CentOS 7 VMs on LVs which are formatted and deployed from an image on dom0 and don't have any partition table. This makes snapshotting, mounting, backing up and migrating very simple. We have written a number of scripts over the years that needed extensive modification to work with HVM VMs but in the end we ended up doing it because we couldn't get PV mode working. And we accepted that HVM is the future so might as well take the opportunity to adapt our ways.

If anyone manages to get PV mode working I'd still like to know.


On September 19, 2020 7:08:28 PM GMT+02:00, "Radosław Piliszek" <radoslaw.piliszek at gmail.com> wrote:
>In general, PV tends not to be supported in newer distribution
>This is mostly due to HVM performance and flexibility nowadays, which
>just was not the case back in the days when PV ruled.
>I am curious why you are trying PV.
>On Sat, Sep 19, 2020 at 6:41 PM 9f9dcad3f78905b03201--- via
>CentOS-virt <centos-virt at centos.org> wrote:
>> All,
>> Just wanted to check one last time before letting this thread die.
>> I am curious if anyone has gotten CentOS 8 to work in a PV Xen
>> Thanks.
>> <9f9dcad3f78905b03201 at bcirpg.com> wrote:
>> >All,
>> >
>> >I have successfully installed CentOS 7 on a PV environment, and have
>been trying to see if I can can get a CentOS 8 install running.
>> >
>> >Hardware does not support virtualization extensions, hence the PV
>environment and I cant do HVM for the install then migrate.
>> >
>> >My understanding is that PV support is in the kernel, and that the
>distro of Linux shouldn't technically matter. But currently when
>trying to "PXEBoot" using a CentOS 8 kernel and ram image I
>get a near instant crash for an invalid kernel.
>> >
>> >I tried to get around the issue by using DOM0 kernel and Ram Disk
>for the install (DOM0 is Debian 10), having the boot progress until it
>reaches the following, looping ISCSI error:
>> >
>> >>[  OK  ] Reached target Slices.
>> >>         Starting Create Static Device Nodes in /dev...
>> >>[  OK  ] Started iSCSI UserSpace I/O driver.
>> >>[  OK  ] Started Setup Virtual Console.
>> >>         Starting dracut cmdline hook...
>> >>[  OK  ] Started Apply Kernel Variables.
>> >>[  OK  ] Stopped iSCSI UserSpace I/O driver.
>> >>         Starting iSCSI UserSpace I/O driver...
>> >
>> >I have also tried the CentOS 7 kernel Ram Disk with the same
>> >
>> >I even tried installing CentOS 7 clean, then upgrading in place (by
>unofficial and unsupported means) and was left with an error that
>pygrub couldnt find the partition with the kernel.
>> >
>> >Is this is a bug, or is PV just not supported? Or am I doing
>something wrong?
>> >
>> >Config for the install is below:
>> >
>> >># Kernel paths for install
>> >>#kernel =
>> >>kernel = "/vmlinuz"
>> >>#ramdisk =
>> >>ramdisk = "/initrd.img"
>> >>extra="modules=loop,squashfs console=hvc0"
>> >>
>> >># Path to HDD and iso file
>> >>disk = [
>> >>        #'file:/vmdisk0,xvda,w'
>> >>        'format=raw, vdev=xvda, access=w,
>> >>       ]
>> >>
>> >>extra="ksdevice=
>> >>
>> >># Network configuration
>> >>vif = ['bridge=xenbr0']
>> >>
>> >>#DomU Settings
>> >>memory = 3072
>> >>name = "centos-8.2"
>> >
>> >Thank you to all.
>> >_______________________________________________
>> >CentOS-virt mailing list
>> >CentOS-virt at centos.org
>> >https://lists.centos.org/mailman/listinfo/centos-virt
>> _______________________________________________
>> CentOS-virt mailing list
>> CentOS-virt at centos.org
>> https://lists.centos.org/mailman/listinfo/centos-virt
>CentOS-virt mailing list
>CentOS-virt at centos.org

Chris Wik
Anu Internet Services
www.cwik.ch | www.anu.net
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.centos.org/pipermail/centos-virt/attachments/20200919/1178224b/attachment.html>

More information about the CentOS-virt mailing list