[CentOS-virt] CentOS 8 Install as DOMU in PV Environment

Sat Sep 19 16:41:10 UTC 2020
9f9dcad3f78905b03201 at bcirpg.com <9f9dcad3f78905b03201 at bcirpg.com>


Just wanted to check one last time before letting this thread die.

I am curious if anyone has gotten CentOS 8 to work in a PV Xen environment.


<9f9dcad3f78905b03201 at bcirpg.com> wrote:
>I have successfully installed CentOS 7 on a PV environment, and have been trying to see if I can can get a CentOS 8 install running.
>Hardware does not support virtualization extensions, hence the PV environment and I cant do HVM for the install then migrate.
>My understanding is that PV support is in the kernel, and that the distro of Linux shouldn't technically matter. But currently when trying to "PXEBoot" using a CentOS 8 kernel and ram image I get a near instant crash for an invalid kernel.
>I tried to get around the issue by using DOM0 kernel and Ram Disk for the install (DOM0 is Debian 10), having the boot progress until it reaches the following, looping ISCSI error:
>>[  OK  ] Reached target Slices.
>>         Starting Create Static Device Nodes in /dev...
>>[  OK  ] Started iSCSI UserSpace I/O driver.
>>[  OK  ] Started Setup Virtual Console.
>>         Starting dracut cmdline hook...
>>[  OK  ] Started Apply Kernel Variables.
>>[  OK  ] Stopped iSCSI UserSpace I/O driver.
>>         Starting iSCSI UserSpace I/O driver...
>I have also tried the CentOS 7 kernel Ram Disk with the same results.
>I even tried installing CentOS 7 clean, then upgrading in place (by unofficial and unsupported means) and was left with an error that pygrub couldnt find the partition with the kernel.
>Is this is a bug, or is PV just not supported? Or am I doing something wrong?
>Config for the install is below:
>># Kernel paths for install
>>#kernel = "/var/opt/xen/ISO_Store/Centos8PXEBoot/vmlinuz"
>>kernel = "/vmlinuz"
>>#ramdisk = "/var/opt/xen/ISO_Store/Centos8PXEBoot/initrd.img"
>>ramdisk = "/initrd.img"
>>extra="modules=loop,squashfs console=hvc0"
>># Path to HDD and iso file
>>disk = [
>>        #'file:/vmdisk0,xvda,w'
>>        'format=raw, vdev=xvda, access=w, target=/dev/mapper/vg_1-virtualmachine',
>>       ]
>>extra="ksdevice= inst.repo=https://mirror.jaleco.com/centos/8.2.2004/isos/x86_64/ nameserver="
>># Network configuration
>>vif = ['bridge=xenbr0']
>>#DomU Settings
>>memory = 3072
>>name = "centos-8.2"
>Thank you to all.
>CentOS-virt mailing list
>CentOS-virt at centos.org