[Centos] Error: yum install compat-db

Lance Davis lance at uklinux.net
Tue Apr 13 22:04:38 UTC 2004

On Tue, 13 Apr 2004, Sorisio, Chris wrote:

> Hola folks, I'm new to Centos and giving it a whirl in a test setting.
> When I try to execute 'yum install compat-db', I receive the following
> error:
> Error: Could not find the GPG Key necessary to validate pkg
> /var/cache/yum/base/packages/compat-libstdc++-7.3-2.96.123.i386.rpm
> Error: You may want to run yum clean or remove the file:
>  /var/cache/yum/base/packages/compat-libstdc++-7.3-2.96.123.i386.rpm
> Error: You may also check that you have the correct GPG keys installed

> Any suggestions on what to try next?

Hmm - you should have the key installed ...

Was it a fresh install or an upgrade ???

try rpm --import http://mirror.centos.org/centos-3/3.1/i386/RPM-GPG-KEY-CentOS-3

that should sort it out .


uklinux.net - The ISP of choice for the discerning Linux user. 

More information about the CentOS mailing list