[Centos] Yum update fails with GPG key

Tue Jun 15 16:25:58 UTC 2004
jack at leadershipbynumbers.com <jack at leadershipbynumbers.com>

I'm getting ready to upgrade to Centos-3.1, but I have a database
application that is having difficulty. It needs the libstdc++ libraries.
When I run it, it generates the following message:
error while loading shared libraries: libstdc++-libc6.1-1.so.2: cannot open
shared object file: No such file or directory
Well, this error doesn't look so bad, as long as I can run Yum on it and
get the libraries. Unfortunately, the Yum install fails with a bad GPG key.
I've done this Yum install on Centos-2 (for the same library), so I'm not
sure why I'm seeing a failure.
Here's what I see when I run Yum (I added the -t hoping to ignore the
[root at linux root]# yum -t install compat-libstdc++
Gathering header information file(s) from server(s)
Server: CentOS-3.1 - Addons
Server: CentOS-3.1 - Base
Server: CentOS-3.1 - Extras
Server: CentOS-3.1 - Updates
Finding updated packages
Downloading needed headers
Resolving dependencies
Dependencies resolved
I will do the following:
[install: compat-libstdc++ 7.3-2.96.128.i386]
Is this ok [y/N]: y
Getting compat-libstdc++-7.3-2.96.128.i386.rpm
compat-libstdc++-7.3-2.96 100% |=========================| 1.0 MB 00:23
warning: rpmts_HdrFromFdno: V3 DSA signature: NOKEY, key ID 025e513b
Error: Could not find the GPG Key necessary to validate pkg
Error: You may want to run yum clean or remove the file:
Error: You may also check that you have the correct GPG keys installed

If you have any ideas how to get the libraries, that would be a big help to
finishing this move.

All the best,

 Jack at leadershipbynumbers.com