Getting kernel panic when installer starts formatting partitions. Was: [Centos] How to get 3Ware 9500S controller card working in CentOS 3.1?

Tue Sep 14 20:41:06 UTC 2004
David Corredor <tecnico at>

In regard of the e-mail sent on Jul/16/04 about the 3Ware 9500S.

 Has anyone experienced/solved this issue ?? I'm having a similar problem, I 
already have the system installed on a separate disk, now I want to make the 
filesystem on the RAID partition (using 3Ware 9500S-8). 

 First I had the problem that the card will keep resetting after continous 
timeouts whenever I tried loading the module (compiled from source, in 
up-mode, driver v.9.2 from 3Ware's website). The solution to this was to 
disable APIC on the motherboard (or boot linux without APIC support).

 So, now the module loads ok (I've tried SMP and ENT versions, I'm using 
kernel 2.4.21-15.0.4-ELsmp). But the timeout and reset problem start 
happening again when I try to create the filesystem on the RAID partition. I 
can cancel the mkfs operation, but then I get a kernel panic if I try to 
unload the module (rmmod 3w-9xxx), just like the problem that the previous 
poster had.

Any ideas or input would be appreciated.