[CentOS] Problems joining Samba toa w2000 AD PDC

Wed Apr 6 16:35:11 UTC 2005
Mário Gamito <lists at tuxdoit.com>

Hi Sean,

No, i did nothing to krb5.conf
Didn't find any reference to that.

Can you send me your example, please ?

I only put

tux.dte.ua.pt   TUX.DTE.UA.PT

in krb.realms

Warm Regards,
Mário Gamito

Sean O'Connell wrote:
 > On Wed, 2005-04-06 at 11:19 +0100, Mário Gamito wrote:
 >>I have this (Linux) Samba file server, that indeed is a client of a
 >>Windows 2000 Server PDC, using Active Directory.
 >>I am the Samba machine admin, but not the Windows one.
 >>I have to join the Samba machine to the PDC on the 2000 server.
 >>I ask the Windows 2000 server admin to come to my Samba machine and
 >>insert his login and password to join my machine, but i always get the
 >>same error (after my signature, along with other relevant data).
 >>I tried:
 >># net ads join -Uzbr at dte.ua.pt
 >>What could be causing the error ?
 >>Another question.:
 >>In the moment of joining the Samba machine to the PDC on the Windows
 >>2000 Server, the Samba daemons must be up or down (i've read
 >>contraditory things about this issue) ?
 >>Any help would be apreciated.
 >>Warm Regards,
 >>Mário Gamito
 >>[root at tux moreira]# # net ads join -Uzbr at dte.ua.pt
 >>foobar at foobar.pt's password:
 >>[2005/04/06 09:24:16, 0]
 >>   ads_connect: Cannot find KDC for requested realm
 >>[root at tux moreira]#
 > Mario-
 > Have you fixed your /etc/krb5.conf to reflect your AD domain? Can you
 > kinit as zbr? I had a similar problem with kinit, and it turned out that
 > I had not fully configured my krb5.conf to reflect our AD domain (still
 > had some references to EXAMPLE.COM .. d'oh :)
 > Hope that helps,
 > Sean