[CentOS] aacraid strangeness

Thu Aug 11 16:38:59 UTC 2005
Aleksandar Milivojevic <alex at milivojevic.org>

I've just had an strange thing with Adapted 2200 RAID controller (with optional
battery module installed).

Basically, new card, worked perfectly for weeks, several reboots and stuff. 
Then all the sudden, when I rebooted machine this today, system would simply
freeze during boot.  BIOS showed the card initialized properly, kernel module
was loaded (from initrd) and it found all of the arrays, and then the system
would freeze at "initializing hardware: storage" step.  Booting in rescue mode
would freeze just after kernel was loaded.  Opened box, unplugged the card,
booted without it, system works.  Plugged it back in, and now everything works
perfectly again!?

Most likely it's not "baddly plugged card".  I've visually checked for that, the
card was plugged seated properly in PCI slot.  Both the motherboard and card are
just weeks old, so I would rule out oxydation on the connectors.  Anyhow, BIOS
initialization was fine, and BIOS utilities worked perfectly.  Device driver
behaving strangly?

Anybody else saw the same problem, or even better yet, knows of an solution ;-)

This message was sent using IMP, the Internet Messaging Program.