[CentOS] Compiling lirc on centos 4.1

Fri Aug 12 13:58:50 UTC 2005
Jerry Geis <geisj at pagestation.com>


I am still having problems. I grabbed the rpm and installed it. I could not get a /dev/lircd device.
I put the lirc.rules in /etc/udev/... even rebooted and still not there.

I then grabbed the src rpm, went through the normal stuff and tried to run ./configure and it tells
me I need the kernel source installed. I have the kernel source installed.

I am just selecting the default of serial when I run ./configure.

I would like to do this from the source package - but the kernel source keeps stopping that...

Any further ideas? 


Jerry Geis wrote:

>/ I am trying to compile lirc.0.7.1 from www.lirc.org and it is indiacting 
/>/ that
/>/ kernel source is not installed.
/>/ I then installed kernel source and ran the ./configure again. Same message
/>/ about kernel not being installed.
/>/ ANyone compiled lirc.0.7.1 on centos 4.1?
You can get a pre-built lirc-0.7.1 for i386 at :

the source for it is 

You might want to take a look at how its packaged, make changes etc in 
the .spec and rebuild for your own needs.

- KB
Karanbir Singh   : http://www.karan.org/
GnuPG Public Key : http://www.karan.org/publickey.asc