[CentOS] php help please

Wed Aug 24 15:25:28 UTC 2005
Melinda Odom <info at designhosting.biz>


My system uses CentOS 3.5 plus Plesk 7.5.3 reloaded for the server
administration for customers. Qmail is the MTA.

A couple of days ago I ran yum list updates and there were these packages to
php                                 i386   4.3.2-25.ent.centos.1    update
php-imap                            i386   4.3.2-25.ent.centos.1    update
php-mysql                           i386   4.3.2-25.ent.centos.1    update
php-pgsql                           i386   4.3.2-25.ent.centos.1    update

When I ran yum update they all updated and seemed like everything was fine.

Then I found out that all of my ecommerce stores using osCommerce had an
error in the admin that could not send mail and it seemed to be isolated to
the admin until I tried to put an order through on my test store and other
live stores where the same error showed up while trying to checkout so
nobody could check out or order anything. 
This is the error:
Fatal error: Call to undefined function: mail() in
/home/httpd/vhosts/domain.com/httpdocs/admin/includes/classes/email.php on
line 502

The server support people eventually put back those php listings to
php-4.3.2-24.ent to solve the problem so people could shop.  In the meantime
the php.ini file had a listing in it called:
; For Unix only.  You may supply arguments as well (default: "sendmail -t
sendmail_path = /usr/sbin/sendmail -t -i
which was used with php-4.3.2-24

was changed to:
; For Unix only.  You may supply arguments as well (default: "sendmail -t
sendmail_path = /var/qmail/bin/sendmail -t -i
when it was updated to php-4.3.2-25

Now that the server is back using php-4.3.2-24 the listing is:
; For Unix only.  You may supply arguments as well (default: "sendmail -t
sendmail_path = /var/qmail/bin/sendmail -t -i
I have left this as is for the moment.

Further, support said the reason the yum update caused these problems was
because there were no mail extensions in the php updates so they put this
line in the yum.conf to keep further conflicts that may arise with Plesk:
exclude=mod_ssl* httpd* perl mysql* php*
For nearly a year I have been doing yum updates without any line like this
in the yum.conf file and am now afraid to run any security updates if my
ecommerce stores are going to stop working.  Plesk says in any of their
updates to check and see if you have this program or better which I have
always had a better version than what they suggest on the server.

Also, in the /etc/redhat-release file I have had this listing from the
beginning in it so I could use the Plesk updater within the Plesk server
admin area:
Red Hat Enterprise Linux ES release 3 (Taroon Update 4)
The server support people are now telling me to put it to CentOS which I
have been asking them about this for months now and only now are they
telling me this:
CentOS release 3.4 (final)
This setting causes the Plesk updater within the Plesk server admin area to
have this error so I cannot use this listed as is:
Error: You are using CentOS Linux 2.2, but autoinstaller was compiled for
RedHat Enterprise Linux 3. Exiting autoinstaller...

Is this line, exclude=mod_ssl* httpd* perl mysql* php* really suppose to be
in the yum.conf file?

Since Plesk supports CentOS 3.3 and Redhat Enterprise 3 should I be able to
update mod_ssl, httpd, perl mysql, and php via yum update without these
problems I would think?

There is only one problem that is happening now and it is just on my
personal domain with my test osCommerce store...I get the order and contact
emails but when I log into the admin to send a status email from the
orders/edit section the email never hits the server using "tail" to watch
for it and I never get the email.  However, I can put an order through one
of my other store sites and use this order/edit status email function and
get the email all the time so this problem is specific to my personal domain
only with a fresh install of the osCommerce store so don't understand this
at all.

I hope I have posted the information necessary and that someone can help me.

Thank you.

Melinda Odom

No virus found in this outgoing message.
Checked by AVG Anti-Virus.
Version: 7.0.338 / Virus Database: 267.10.15/80 - Release Date: 8/23/2005
-------------- next part --------------
A non-text attachment was scrubbed...
Name: winmail.dat
Type: application/ms-tnef
Size: 4140 bytes
Desc: not available
URL: <http://lists.centos.org/pipermail/centos/attachments/20050824/e64a6e7a/attachment-0004.bin>