[CentOS] remove RPMs with cyclic dependancies.

Thu Aug 4 17:28:24 UTC 2005
Matt Hyclak <hyclak at math.ohiou.edu>

On Fri, Aug 05, 2005 at 02:28:08AM +0900, Dave Gutteridge enlightened us:
> Okay, I tried installing OpenOffice beta, and I think I messed it up, so 
> I wanted to uninstall it.
> I thought wilcards worked, so I tried:
> [root at localhost program]# rpm -e openoffice*
> error: package openoffice* is not installed
> Okay, so I couldn't figure out how to remove a bunch of RPM packages at 
> once, so I did this:
> [root at localhost program]#  rpm -qa | grep openoffice
> And proceeded the labourous task of removing all of the RPMs listed one 
> by one.
> But then I got down to some files that would say:
> rpm -e openofficeorg-core01-1.9.122-1.i586
> error: Failed dependencies:
>        openofficeorg-core01 is needed by (installed) 
> openofficeorg-core08-1.9.122-1.i586
> So then I'd remove the dependancy, and guess what?:
> rpm -e openofficeorg-core08-1.9.122-1.i586
> error: Failed dependencies:
>        openofficeorg-core01 is needed by (installed) 
> openofficeorg-core01-1.9.122-1.i586
> The two packages are dependant on each other so I can't remove either.
> *sigh*
> So, how do I remove them?

# rpm -e openofficeorg-core01 openofficeorg-core08


Matt Hyclak
Department of Mathematics 
Department of Social Work
Ohio University
(740) 593-1263
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
URL: <http://lists.centos.org/pipermail/centos/attachments/20050804/3809f2bd/attachment-0005.sig>