[CentOS] xfs module not loading

Fri Aug 19 15:17:10 UTC 2005
James Pearson <james-p at moving-picture.com>

Fong Vang wrote:
>>My guess is that these modules don't match the running installer kernel.
>>I think you should really start from scratch - get hold of the
>>CentOSPlus kernel RPMS and xfsprogs RPM and rebuild the installer -
>>hacking modules into the various installer images is very unlikely to
>>work and difficult to maintain - I've tried it before, but it is so much
>>simpler to rebuild the installer (once you've worked out what to do) ...
> What do you mean by rebuild the installer?  I wonder what could be
> different since I am using rpmbuild to build the i586 kernel then
> copying just the new modules I'm interested in.

That's likely to be you're problem - the kernel modules from a rebuilt 
kernel RPM probably won't match the kernel in the installer.

Rebuilding the installer with and an XFS enabled kernel will result in a 
working installer ... as you've seen, hacking the installer by adding 
modules, doesn't work - that is the main difference ...

James Pearson