[CentOS] YUM is seriously fubar

Mon Aug 22 20:23:18 UTC 2005
Bryan J. Smith <b.j.smith at ieee.org>

On Mon, 2005-08-22 at 21:47 +0200, Dag Wieers wrote:
> I can't. I just know JBJ often repeated the warning.

Yep, I saw it too.  I had a RHL8.0 installation get seriously fubar'd as
a result.

> Also, cache corruption should not happen on a stable system anymore.
> Those bugs have been fixed. But if you do encounter this, try to reproduce,
> check you hardware and then contact JBJ.

I ran into it all-the-time under RHL8.0, but RHL9 seem to fixed almost

I think I had maybe 2 issues with RHL9 and 1 with FC1, and I never did
again.  And in all cases of the RHL9/FC1 issues, those were systems that
were originally RHL8 (possibly RHL7.3) and had been upgraded to RHL9/FC1
from it.

> I am not sure if it has any effect on a system with an existing rpmdb. 
> Never used it for that.

What I ran into with RHL9/FC1 was that the system expected some sort of
"initial db cache."  Deleting the files didn't do enough, "--rebuilddb"
had the aforementioned consequences.  I found RHL9 always worked fine
once I did a "--initdb".  It basically started building the cache anew
on any new operation.

Bryan J. Smith     b.j.smith at ieee.org     http://thebs413.blogspot.com
The best things in life are NOT free - which is why life is easiest if
you save all the bills until you can share them with the perfect woman